POJ - 3259 Wormholes(最短路 Bellman-Ford算法)

Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 57342 Accepted: 21388

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively: NM, and W 
Lines 2..M+1 of each farm: Three space-separated numbers (SET) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. 
Lines M+2..M+W+1 of each farm: Three space-separated numbers (SET) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.

Output

Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Code

#include <cstdio>
#include <cstring>
#include <algorithm>
#define N 10000
#define INF 0x3f3f3f3f

using namespace std;

int dis[N];
int n,m,W,num;

struct node
{
    int s,e,t;
}e[N];

bool Bellman_Ford()
{
    int i,j,flag;   ///flag判斷負邊權
    for(i=0;i<n;i++)
    {
        dis[i] = INF;
    }
    dis[1] = 0;
    for(i=0;i<n;i++)
    {
        flag = 0;
        for(j=0;j<num;j++)
        {
            if(dis[e[j].e] > dis[e[j].s] + e[j].t)
            {
                dis[e[j].e] = dis[e[j].s] + e[j].t;
                flag = 1;
            }
        }
        if(!flag)   ///沒有鬆弛,一定沒有負邊
            return false;
    }
    for(i=0;i<num;i++)
    {
        if(dis[e[i].e] > dis[e[i].s] + e[i].t)
            return true;    ///存在負邊
    }
    return false;
}

int main()
{
    int T,i,j;
    scanf("%d",&T);
    while(T--)
    {
        num = 0;
        int u,v,w;
        scanf("%d %d %d",&n,&m,&W);
        for(i=0; i<m; i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            e[num].s = u;
            e[num].e = v;
            e[num].t = w;
            num++;
            e[num].s = v;
            e[num].e = u;
            e[num].t = w;
            num++;
        }
        for(i=0;i<W;i++)
        {
            scanf("%d %d %d",&u,&v,&w);
            e[num].s = u;
            e[num].e = v;
            e[num].t = -w;
            num++;
        }
        if(Bellman_Ford())
            printf("YES\n");
        else
            printf("NO\n");
    }
    return 0;
}

反思:

題目大意:約翰農夫發現農場有蟲洞,因爲他是個狂熱的時間旅行愛好者,所以打算皮一下,想試試能不能通過蟲洞回到起點看到自己。農場的路徑是雙向的,蟲洞是單向的負邊。第一行是數據組數,每組的第一行n,m,w分別是農場數、路徑數和蟲洞數,接下來m行是連接兩邊的點和邊的權值,再接下來w行是存在蟲洞的路徑。最短路問題,存在負權邊,所以選用Bellman-Ford算法。如果存在負權邊,則約翰可以穿越時空看到自己,輸出YES,否則就不可以,輸出NO。

發佈了112 篇原創文章 · 獲贊 8 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章