POJ - 2387 Til the Cows Come Home(最短路 Dijkstra算法)

Til the Cows Come Home
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 63212 Accepted: 21342

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

Code

#include <cstdio>
#include <cstring>
#include <cmath>
#include <algorithm>
#define N 2010
#define INF 0x3f3f3f3f

using namespace std;

int map[N][N];
int dis[N];
int vis[N];
int t,n;

void Dijkstra()
{
    int i,j,pos,minn;
    for(i=1; i<=n; i++)
    {
        dis[i] = map[1][i];
        vis[i] = 0;
    }
    vis[1] = 1;
    for(i=1; i<=n-1; i++)
    {
        minn = INF;
        for(j=1; j<=n; j++)
        {
            if(!vis[j] && dis[j] < minn)
            {
                minn = dis[j];
                pos = j;
            }
        }
        vis[pos] = 1;
        for(j=1; j<=n; j++)
        {
            if(!vis[j] && map[j][pos] != INF && dis[j] > dis[pos] + map[pos][j])
            {
                dis[j] = dis[pos] + map[pos][j];
            }
        }
    }
    printf("%d\n",dis[n]);
}

int main()
{
    int i,j,u,v,w;
    scanf("%d %d",&t,&n);
    for(i=1;i<=n;i++)
    {
        for(j=1;j<=n;j++)
        {
            if(i == j)
                map[i][j] = 0;
            else
                map[i][j] = INF;
        }
    }
    for(i=1; i<=t; i++)
    {
        scanf("%d %d %d",&u,&v,&w);
        if(map[u][v] > w)
            map[u][v] = map[v][u] = w;
    }
    Dijkstra();
    return 0;
}

反思:

題目大意:奶牛Bessie想盡快回家,趕在擠奶之前睡個美容覺,因此需要走最短路徑~第一行輸入t和n,接下來有t行數據,每行三個數據代表兩個點和它們的權值(路徑長度),n是Bessie的目的地,也是圖的大小,Bessie需要從n走到1,求最短路徑的長度。最短路模板題,注意要查重邊!

發佈了112 篇原創文章 · 獲贊 8 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章