hdu 3829 Cat VS Dog 最大點獨立集

 

 

Problem Description
The zoo have N cats and M dogs, today there are P children visiting the zoo, each child has a like-animal and a dislike-animal, if the child's like-animal is a cat, then his/hers dislike-animal must be a dog, and vice versa.
Now the zoo administrator is removing some animals, if one child's like-animal is not removed and his/hers dislike-animal is removed, he/she will be happy. So the administrator wants to know which animals he should remove to make maximum number of happy children.

 

Input
The input file contains multiple test cases, for each case, the first line contains three integers N <= 100, M <= 100 and P <= 500.
Next P lines, each line contains a child's like-animal and dislike-animal, C for cat and D for dog. (See sample for details)

 

Output
For each case, output a single integer: the maximum number of happy children.
 

Sample Input
1 1 2
C1 D1
D1 C1

1 2 4
C1 D1
C1 D1
C1 D2
D2 C1
 

Sample Output
1
3

HintCase 2: Remove D1 and D2, that makes child 1, 2, 3 happy.


//
#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
using namespace std;

const int N=600;//N不能太大 否則超時
int cap[N][N];//初始化要清零
int _link[N];
bool used[N];
int nx,ny;//1->nx
bool _find(int t)
{
    for(int i=1;i<=ny;i++)

    if(!used[i]&&cap[t][i]==1)
    {
        used[i]=true;
        if(_link[i]==-1||_find(_link[i]))
        {
            _link[i]=t;
            return true;
        }
    }
    return false;
}
int MaxMatch()
{
    int num=0;
    memset(_link,-1,sizeof(_link));
    for(int i=1;i<=nx;i++)
    {
        memset(used,false,sizeof(used));
        if(_find(i))   num++;
    }
    return num;
}
string a[600],b[600];
//最大點獨立集=P-最大匹配
//只有喜歡貓和喜歡狗的人會發生衝突,有用的總人數爲p
//如果兩邊發生衝突,則連一條邊
//這樣求的是最多不發生衝突的人個數,即最大點獨立集
int main()
{
    int n,m,p;
    while(scanf("%d%d%d",&n,&m,&p)==3)
    {
        for(int i=1;i<=p;i++)
        {
            cin>>a[i]>>b[i];
        }
        memset(cap,0,sizeof(cap));
        nx=ny=p;
        for(int i=1;i<=p;i++)
        {
            if(a[i][0]=='C')//喜歡貓的人
            for(int j=1;j<=p;j++)
            {
                if(a[j][0]=='D')//喜歡狗的人
                if(a[i]==b[j]||a[j]==b[i])//如果發生衝突
                {
                    cap[i][j]=1;
                }
            }
        }
        int ans=MaxMatch();
        printf("%d\n",p-ans);
    }
    return 0;
}

發佈了743 篇原創文章 · 獲贊 5 · 訪問量 69萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章