hdu 1466 Girls and Boys 最大點獨立集=N-最大匹配

Description

In the second year of the university somebody started a study on the romantic relations between the students. The relation "romantically involved" is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been "romantically involved". The result of the program is the number of students in such a set.

Input

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1 (n <=500 ), for n subjects.

Output

For each given data set, the program should write to standard output a line containing the result.

Sample Input

7
0: (3) 4 5 6
1: (2) 4 6
2: (0)
3: (0)
4: (2) 0 1
5: (1) 0
6: (2) 0 1
3
0: (2) 1 2
1: (1) 0
2: (1) 0

Sample Output

5
2

 

 //

 

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;

const int N=600;//N不能太大 否則超時
int cap[N][N];//初始化要清零
int _link[N];
bool used[N];
int nx,ny;//1->nx
bool _find(int t)
{
    for(int i=1;i<=ny;i++)

    if(!used[i]&&cap[t][i]==1)
    {
        used[i]=true;
        if(_link[i]==-1||_find(_link[i]))
        {
            _link[i]=t;
            return true;
        }
    }
    return false;
}
int MaxMatch()
{
    int num=0;
    memset(_link,-1,sizeof(_link));
    for(int i=1;i<=nx;i++)
    {
        memset(used,false,sizeof(used));
        if(_find(i))   num++;
    }
    return num;
}
//最大點獨立集=N-最小點覆蓋=N-最大匹配
//此題中男女關係重複兩次,所以最後要N-最大匹配/2
int main()
{
    int n;
    while (scanf("%d",&n) != EOF)
    {
        nx=ny=n;
        //輸入數據並進行初始化
        memset(cap,0,sizeof(cap));
        for (int i=1;i<=n;i++)
        {
            int x;
            scanf("%d : (%d)",&x,&x);
            for (int j=1;j<=x;j++)
            {
                int y;scanf("%d",&y);y++;
                cap[i][y]=1;
            }
        }
        printf("%d\n",n-MaxMatch()/2); //輸出最大獨立集
    }
    return 0;
}

 

 

發佈了743 篇原創文章 · 獲贊 5 · 訪問量 69萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章