質數環

HDOJ1016 Prime Ring Problem(DFS第二層理解)

Problem Description
A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.

 

 

Input
n (0 < n < 20).
 

 

Output
The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.
 

 

Sample Input
6 8
 

 

Sample Output
Case 1:
1 4 3 2 5 6
1 6 5 2 3 4
Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2

思路:
先將40以內的素數進行標記,然後從1開始進行dfs()搜索。

代碼:
#include<iostream>
#include<string.h>
using namespace std;
int prime[40]={0,1,1,1,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,1,0,0,0,1,0,0,0,0,0,1,0,1,0,0,0,0,0,1,0,0},n;//素數打表,因爲n最大是20,所以只要打到40
int visited[21],a[21];
void dfs(int num)//深搜
{
   int i;
   if(num==n&&prime[a[num-1]+a[0]])  //滿足條件了,就輸出來
   {
       for(i=0;i<num-1;i++)
           printf("%d ",a[i]);
       printf("%d\n",a[num-1]);
   }
   else
   {
       for(i=2;i<=n;i++)
       {
           if(visited[i]==0)//是否用過了
           {
               if(prime[i+a[num-1]]) //是否和相鄰的加起來是素數
               {
                   visited[i]=-1;//標記了
                   a[num++]=i;//放進數組
                   dfs(num); //遞歸調用
                   visited[i]=0; //退去標記
                   num--;
               }
           }
       }
   }
}    
int main()
{
      int num=0;
      while(cin>>n)
      {
         num++;
         printf("Case %d:\n",num);
         memset(visited,0,sizeof(visited));
         a[0]=1;
         dfs(1);
         printf("\n");
      }
      return 0;
}
發佈了33 篇原創文章 · 獲贊 4 · 訪問量 2萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章