Knight Moves POJ - 1915

Background 
Mr Somurolov, fabulous chess-gamer indeed, asserts that no one else but him can move knights from one position to another so fast. Can you beat him? 
The Problem 
Your task is to write a program to calculate the minimum number of moves needed for a knight to reach one point from another, so that you have the chance to be faster than Somurolov. 
For people not familiar with chess, the possible knight moves are shown in Figure 1.

Input
The input begins with the number n of scenarios on a single line by itself. 
Next follow n scenarios. Each scenario consists of three lines containing integer numbers. The first line specifies the length l of a side of the chess board (4 <= l <= 300). The entire board has size l * l. The second and third line contain pair of integers {0, ..., l-1}*{0, ..., l-1} specifying the starting and ending position of the knight on the board. The integers are separated by a single blank. You can assume that the positions are valid positions on the chess board of that scenario.
Output
For each scenario of the input you have to calculate the minimal amount of knight moves which are necessary to move from the starting point to the ending point. If starting point and ending point are equal,distance is zero. The distance must be written on a single line.
Sample Input
3
8
0 0
7 0
100
0 0
30 50
10
1 1
1 1
Sample Output
5
28
0

解题思路:
这是一道bfs的题目,还是很明显的,结构体里保存座标值以及步数,最先到达的肯定是步数最少的,也是最先找到的,这也是bfs的性质

代码:
#include<iostream>
#include<queue>
#include<cstring>
#include<cmath>
using namespace std;
int hang;
int vis[305][305];
int dis[][2] = {{1,2},{2,1},{2,-1},{1,-2},{-1,-2},{-2,-1},{-2,1},{-1,2}};
struct node
{
    int x;
    int y;
    int num;
};
node beginn;
node endd;

bool ok(int a,int b)
{
    if(a>=0&&a<hang&&b>=0&&b<hang)
        return true;
    else return false;
}

int bfs(node now)
{
    node help;
    node help2;
    queue<node> q;
    q.push(now);
    int ans = 0;
    vis[now.x][now.y] = 1;
    while(!q.empty())
    {
        help = q.front();
        q.pop();
        for(int i = 0;i<8;i++)
        {
            help2.x = help.x+dis[i][0];
            help2.y = help.y+dis[i][1];
            help2.num = help.num+1;
            if(help2.x==endd.x&&help2.y==endd.y)
                return help2.num;
            if(!vis[help2.x][help2.y]&&ok(help2.x,help2.y))
            {
                q.push(help2);
                vis[help2.x][help2.y] = 1;
                //cout<<"help2  "<<help2.x<<" "<<help2.y<<endl;
               // ans++;
            }
        }
    }
    return help2.num;
}

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        memset(vis,0,sizeof(vis));
        cin>>hang;
        cin>>beginn.x>>beginn.y>>endd.x>>endd.y;
        beginn.num = 0;
        endd.num = 0;
        if(beginn.x==endd.x&&beginn.y==endd.y)
        {
            cout<<"0"<<endl;
            continue;
        }
        //cout<<"end "<<endd.x<<" "<<endd.y<<endl;
        int re = bfs(beginn);
        cout<<re<<endl;
    }
}


发布了79 篇原创文章 · 获赞 1 · 访问量 8910
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章