HDU 4268 Alice and Bob(貪心)


  

Alice and Bob

                                                               Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)


Problem Description
Alice and Bob's game never ends. Today, they introduce a new game. In this game, both of them have N different rectangular cards respectively. Alice wants to use his cards to cover Bob's. The card A can cover the card B if the height of A is not smaller than B and the width of A is not smaller than B. As the best programmer, you are asked to compute the maximal number of Bob's cards that Alice can cover.
Please pay attention that each card can be used only once and the cards cannot be rotated.
 

Input
The first line of the input is a number T (T <= 40) which means the number of test cases. 
For each case, the first line is a number N which means the number of cards that Alice and Bob have respectively. Each of the following N (N <= 100,000) lines contains two integers h (h <= 1,000,000,000) and w (w <= 1,000,000,000) which means the height and width of Alice's card, then the following N lines means that of Bob's.
 

Output
For each test case, output an answer using one line which contains just one number.
 

Sample Input
2
2
2 3
1 4
4 5
2 3
3 2 3
5 7 6 8 4 1
2 5 3 4
 

Sample Output
1
2
 

Source
 

Recommend
liuyiding
題目大意:

Alice和Bob手中都有N張排,每張牌都有自己的長H和寬W,當Alice牌的長和寬都大於等於Bob時,就說Alice的牌能夠覆蓋Bob的牌,問Alice最多能覆蓋多少張Bob的牌,每張牌只能用一次。

解題思路:

先對Alice和Bob的牌按照H(or W)從大到小排序,然後從Alice牌中挑出比Bob【i】.H大的牌放進multiset , 再在set裏面找出第一個比Bob【i】.W大的,然後釋放set裏面的這個元素且個數加一,再進行下一個Bob的元素。。。


代碼:

#include<iostream>
#include<cstdio>
#include<set>
#include<algorithm>

using namespace std;

const int maxN=110000;
int n;

struct node{
    int h,w;
    node(int h0=0,int w0=0){
        h=h0,w=w0;
    }
    friend bool operator <(node a,node b){
        if(a.w!=b.w) return a.w<b.w;
        else return a.h<b.h;
    }
}Alice[maxN],Bob[maxN];

bool cmp(node a,node b){
    if(a.h!=b.h) return a.h>b.h;
    else return a.w>b.w;
}

void solve(){
    multiset <node> mul;
    sort(Alice,Alice+n,cmp);
    sort(Bob,Bob+n,cmp);
    int r=0,cnt=0;
    for(int i=0;i<n;i++){
        while(r<n&&Alice[r].h>=Bob[i].h) mul.insert(Alice[r++]);
        multiset<node>::iterator it=mul.lower_bound(Bob[i]);
        if(it!=mul.end()){
            mul.erase(it);
            cnt++;
        }
    }
    cout<<cnt<<endl;
}

int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<n;i++) scanf("%d%d",&Alice[i].h,&Alice[i].w);
        for(int i=0;i<n;i++) scanf("%d%d",&Bob[i].h,&Bob[i].w);
        solve();
    }
}


發佈了71 篇原創文章 · 獲贊 5 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章