HDU 4296 Buildings(貪心)


Buildings

Time Limit: 5000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)



Problem Description
  Have you ever heard the story of Blue.Mary, the great civil engineer? Unlike Mr. Wolowitz, Dr. Blue.Mary has accomplished many great projects, one of which is the Guanghua Building.
  The public opinion is that Guanghua Building is nothing more than one of hundreds of modern skyscrapers recently built in Shanghai, and sadly, they are all wrong. Blue.Mary the great civil engineer had try a completely new evolutionary building method in project of Guanghua Building. That is, to build all the floors at first, then stack them up forming a complete building.
  Believe it or not, he did it (in secret manner). Now you are face the same problem Blue.Mary once stuck in: Place floors in a good way.
  Each floor has its own weight wi and strength si. When floors are stacked up, each floor has PDV(Potential Damage Value) equal to (Σwj)-si, where (Σwj) stands for sum of weight of all floors above.
  Blue.Mary, the great civil engineer, would like to minimize PDV of the whole building, denoted as the largest PDV of all floors.
  Now, it’s up to you to calculate this value.
 

Input
  There’re several test cases.
  In each test case, in the first line is a single integer N (1 <= N <= 105) denoting the number of building’s floors. The following N lines specify the floors. Each of them contains two integers wi and si (0 <= wi, si <= 100000) separated by single spaces.
  Please process until EOF (End Of File).
 

Output
  For each test case, your program should output a single integer in a single line - the minimal PDV of the whole building.
  If no floor would be damaged in a optimal configuration (that is, minimal PDV is non-positive) you should output 0.
 

Sample Input
3 10 6 2 3 5 4 2 2 2 2 2 3 10 3 2 5 3 3
 

Sample Output
1 0 2
 

Source


題目大意:

輸入一個整數n,代表有n塊磚塊,再輸入n行,每行兩個整數w,s,分別代表磚頭的重量和強度,當疊在磚塊上的重量之和大於它的強度時,就會有一個虧損,虧損值爲:此磚塊上面的總質量-此磚塊的強度值,當小於0時,爲0,現在已所有磚塊中最大的虧損值來代表整個建築的虧損值,輸出這個虧損值。

解題思路:

設w,s數組代表重量和強度,設一塊磚塊放在上面爲w[i],s[i],另一塊放在下面爲w[j],s[j],虧損值C1爲w[i]-s[j],第二次倒轉順序,則虧損值C2爲w[j]-s[i];現在主要的問題是排序,如果前者優於後者,則要是PDV最小,即w[i]-s[j]<w[j]-s[i]   ==>  w[i]+s[i]<w[j]+s[j].所以磚塊按照和的從小到大放(最上面放和最小的,最下面放和最大的)。


代碼:

#include<iostream>
#include<cstdio>
#include<algorithm>
#define maxN 100010

using namespace std;

int n;
long long sumWeight[maxN];

struct node{
    int w,s;
    node(int w0=0,int s0=0){
        w=w0,s=s0;
    }
}fl[maxN];

bool cmp(node a,node b){
    return a.w+a.s<b.w+b.s;
}

int main(){
    long long maxCost=0;
    while(scanf("%d",&n)!=EOF){
        for(int i=0;i<n;i++){
            scanf("%d%d",&fl[i].w,&fl[i].s);
        }
        sort(fl,fl+n,cmp);
        sumWeight[0]=fl[0].w;
        maxCost=sumWeight[0]-fl[1].s;
        for(int i=1;i<n-1;i++){
            sumWeight[i]=sumWeight[i-1]+fl[i].w;
            if(sumWeight[i]-fl[i+1].s>maxCost){maxCost=sumWeight[i]-fl[i+1].s;}
        }
        if(maxCost>=0)printf("%I64d\n",maxCost);
        else printf("0\n");
    }
}



發佈了71 篇原創文章 · 獲贊 5 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章