POJ 1936 All in All(string)


All in All
Time Limit: 1000MS   Memory Limit: 30000K
     

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

題目大意:

問是否字符串1是字符串2的子列。

解題思路:

對第一個字符串進行枚舉,然後和第二個字符串匹配,匹配正確記錄位置,然後進行下一個字符的匹配。(匹配是找離當前最近的並且靠右的)。

代碼:

#include<iostream>
#include<cstdio>
#include<string>

using namespace std;

string str1,str2;

void solve(){
    bool ans = true;
    int pos=0;
    for(int i=0;i<str1.length();i++){
            for(int j=pos;j<str2.length();j++){
                if(str1[i]==str2[j]){
                    pos=j+1;
                    break;
                }
                if(j==str2.length()-1&&str2[j]!=str1[i]){
                    ans =false;
                }
            }
    }
    if(!ans) printf("No\n");
    else printf("Yes\n");
}

int main(){
    while(cin>>str1>>str2){//cin都是以空格,tab,換行結束的,getline是以換行結束的.
        solve();
    }
    return 0;
}


發佈了71 篇原創文章 · 獲贊 5 · 訪問量 6萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章