POJ 1936 All in All(string)


All in All
Time Limit: 1000MS   Memory Limit: 30000K
     

Description

You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string. 

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s. 

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output

For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input

sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output

Yes
No
Yes
No

题目大意:

问是否字符串1是字符串2的子列。

解题思路:

对第一个字符串进行枚举,然后和第二个字符串匹配,匹配正确记录位置,然后进行下一个字符的匹配。(匹配是找离当前最近的并且靠右的)。

代码:

#include<iostream>
#include<cstdio>
#include<string>

using namespace std;

string str1,str2;

void solve(){
    bool ans = true;
    int pos=0;
    for(int i=0;i<str1.length();i++){
            for(int j=pos;j<str2.length();j++){
                if(str1[i]==str2[j]){
                    pos=j+1;
                    break;
                }
                if(j==str2.length()-1&&str2[j]!=str1[i]){
                    ans =false;
                }
            }
    }
    if(!ans) printf("No\n");
    else printf("Yes\n");
}

int main(){
    while(cin>>str1>>str2){//cin都是以空格,tab,换行结束的,getline是以换行结束的.
        solve();
    }
    return 0;
}


发布了71 篇原创文章 · 获赞 5 · 访问量 6万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章