Frogger

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2

0 0

3 4


3

17 4

19 4

18 5

Sample Output

Scenario #1

Frog Distance = 5.000


Scenario #2

Frog Distance = 1.414


Source




題目大意:定義“青蛙距離”爲Freddy跳到Fiona那裏所需要的若干次跳躍中最長的那一次。第一行有一個整數n(2<=n<=200),表示湖中一共有多少塊石頭。接下來的n行,每一行有兩個整數xi,yi(0 <= xi,yi <= 1000),表示第i塊石頭的座標。第1塊石頭的座標是Freddy所在的位置,第二塊石頭的座標是Fiona所在的位置,其他的石頭上都沒有青蛙。求青蛙距離。


#include<stdio.h>
#include<limits.h>
#include<math.h>
double firstjump[205];
double map[205][205];
int check[205];											//用於標記第i塊石頭是否被訪問 
int x[205],y[205],n;
double max,min;
void sove()
{
	firstjump[0]=0;
	check[0]=1;
	int begin=0;
	while(begin!=1)
	{
        min=INT_MAX;
        for(int i=0;i<n;i++)
        if(!check[i]&&firstjump[i]<min)
        {
             min=firstjump[i];
             begin=i;										//記錄第一次跳躍後青蛙所在位置 
        }
        if(min>max)  
		max=min;
        for(int i=0;i<n;i++)
        {
            if(!check[i]&&map[begin][i]<INT_MAX&&firstjump[i]>map[begin][i])
            firstjump[i]=map[begin][i];
            check[begin]=1;
        }	
	}
}
int main()
{
	int cas=0;
	while(scanf("%d",&n),n!=0)
	{
		cas++;
		max=INT_MIN;
		for(int i=0;i<n;i++)
		scanf("%d %d",&x[i],&y[i]);
		for(int i=0;i<n;i++)						// 初始化第i塊跳到第j塊的距離 
		for(int j=0;j<n;j++)
		{
			map[i][j]=INT_MAX;
		}
        for(int i=0;i<n;i++)						//計算第i塊跳到第j塊的距離 
        for(int j=0;j<n;j++)
        {
           map[i][j]=sqrt((1.0*x[i]-1.0*x[j])*(1.0*x[i]-1.0*x[j])+(1.0*y[i]-1.0*y[j])*(1.0*y[i]-1.0*y[j]));		
        }
        for(int i=0;i<n;i++)						//第一次跳躍的最短距離 
        {
        	firstjump[i]=map[0][i];
        	check[i]=0;
        }
        sove();
        printf("Scenario #%d\n",cas);
        printf("Frog Distance = %.3f\n",max);
        printf("\n");
	}
	return 0;
}



發佈了31 篇原創文章 · 獲贊 27 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章