Humble Numbers

Humble Numbers

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 20341    Accepted Submission(s): 8869


Problem Description
A number whose only prime factors are 2,3,5 or 7 is called a humble number. The sequence 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 12, 14, 15, 16, 18, 20, 21, 24, 25, 27, ... shows the first 20 humble numbers.

Write a program to find and print the nth element in this sequence
 

Input
The input consists of one or more test cases. Each test case consists of one integer n with 1 <= n <= 5842. Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line saying "The nth humble number is number.". Depending on the value of n, the correct suffix "st", "nd", "rd", or "th" for the ordinal number nth has to be used like it is shown in the sample output.
 

Sample Input
1 2 3 4 11 12 13 21 22 23 100 1000 5842 0
 

Sample Output
The 1st humble number is 1. The 2nd humble number is 2. The 3rd humble number is 3. The 4th humble number is 4. The 11th humble number is 12. The 12th humble number is 14. The 13th humble number is 15. The 21st humble number is 28. The 22nd humble number is 30. The 23rd humble number is 32. The 100th humble number is 450. The 1000th humble number is 385875. The 5842nd humble number is 2000000000.
 

Source
 

Recommend
JGShining   |   We have carefully selected several similar problems for you:  1159 1069 1176 1421 1024 

分析:題目比較好理解,但是由於數據比較大,和原來做過得題類似,想到暴力,結果過了。

然後看後面分析,發現這題是個dp問題。

代碼1:

 #include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int max1=2000000000;
long long  a[100000];
int cmp(int b,int c)
{
return b<c;
}
int main()
{
int i,j,k,n,l,m=0;
for(i=0;i<32&&pow(2,i)<=max1;i++)
for(j=0;j<21&&pow(2,i)*pow(3,j)<=max1;j++)
for(k=0;k<15&&pow(2,i)*pow(3,j)*pow(5,k)<=max1;k++)
for(l=0;l<13&&pow(2,i)*pow(3,j)*pow(5,k)*pow(7,l)<=max1;l++)
{
a[++m]=pow(2,i)*pow(3,j)*pow(5,k)*pow(7,l);
}
sort(a+1,a+m+1,cmp);
while(~scanf("%d",&n)&&n)
{
int flag=0;
printf("The %d",n);
if(n%10==1&&n%100!=11)
{
printf("st");flag=1;
   }
if(n%10==2&&n%100!=12)
{
printf("nd");flag=1;
   }
if(n%10==3&&n%100!=13)
{
printf("rd");flag=1;
}
if(!flag)
    printf("th");
   printf(" humble number is %lld.\n",a[n]);
}
return 0;
}


發佈了110 篇原創文章 · 獲贊 11 · 訪問量 13萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章