Rails,ACM/ICPC CERC 1997,UVa514

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track.

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station.

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0.

The last block consists of just one line containing 0. 

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes

分析:

通過棧來模擬,看看能否按照目標順序進棧和出棧,如果能夠模擬出目標順序的進棧與出棧,那麼模擬成功後,棧內必然爲空,如果模擬失敗,那麼棧內必然會存在元素,然後就可以根據棧是否爲空來輸出YesNo

代碼:

#include <stack>
#include <cstdio>
#include <iostream>
using namespace std;

#define MAXN (1000 + 10)
int n, target[MAXN];

int main(int argc, const char * argv[]) {
    
    while (scanf("%d", &n) && n != 0) {
        //輸入目標順序
        while (scanf("%d", &target[0])) {
            if (target[0] == 0) { //如果組內第一個數爲0,說明結束本組
                printf("\n");
                break;
            } else {
                for (int i = 1; i < n; i++) {
                    scanf("%d", &target[i]);
                }
            }
            int i, j;
            int mark = 1;
            stack<int> s;
            //通過棧來模擬,看看能否按照目標順序進棧和出棧,如果能夠模擬出目標順序的進棧與出棧,那麼模擬成功後,棧內必然爲空,如果模擬失敗,那麼棧內必然會存在元素,然後就可以根據棧是否爲空來輸出Yes或No
            for (i = 0 ; i < n; i++) {
                if (!s.empty() && s.top() == target[i]) {
                    s.pop();
                } else {
                    for (j = mark ; j <= n; j++) {
                        s.push(j);
                        mark++;
                        if (s.top() == target[i]) {
                            s.pop();
                            break;
                        }
                    }
                }
            }
            //如果棧爲空,模擬目標順序進棧出棧成功,輸出Yes,否則,輸出No
            if (s.empty()) {
                printf("Yes\n");
            } else {
                printf("No\n");
            }

        }
        
    }
        
    return 0;
}

發佈了78 篇原創文章 · 獲贊 12 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章