Nightmare-BFS


Nightmare
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes. 

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1. 

Here are some rules: 
1. We can assume the labyrinth is a 2 array. 
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too. 
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth. 
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb. 
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish. 
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6. 
  

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. 
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth. 
There are five integers which indicate the different type of area in the labyrinth: 
0: The area is a wall, Ignatius should not walk on it. 
1: The area contains nothing, Ignatius can walk on it. 
2: Ignatius' start position, Ignatius starts his escape from this position. 
3: The exit of the labyrinth, Ignatius' target position. 
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas. 
  

Output

For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1. 
  

Sample Input

3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
  

Sample Output

4 -1 13
  


題目中描述的是走過的路徑還可以重新再走,也就是說走過的路徑不需要標記。但是當遇到重設爆炸時間的點需要標記,不能再從這裏經過。如果遇到爆炸點不標記的話,那麼這個點就可以無限次數的走,剩餘時間會被重設爲6,那麼剩餘時間永遠都不會消耗完,那麼這個程序也就成了一個死循環。

#include <queue>
#include <string.h>
#include <iostream>
using namespace std;

#define MAXN 10
//定義方向,頂部開始,順時針
int dir[4][2] = {{-1, 0}, {0, 1}, {1, 0}, {0, -1}};
int n, m;
int a[MAXN][MAXN];
int vis[MAXN][MAXN];
int startX, startY; //開始位置
int endX, endY;     //結束位置

struct Node
{
    int x;
    int y;
    int leftTime; //剩餘時間
    int cnt;      //走到當前位置共走了多少步
}now, nextStep;

//判斷結點能否通過
bool isPracticable(Node node)
{
    //當超出邊界,或者剩餘時間爲0,或者遇到障礙物都不能再通過
    if (node.x < 0 || node.x > n || node.y < 0 || node.y > m || node.leftTime <= 0 || a[node.x][node.y] == 0 || vis[node.x][node.y]) {
        return 0;
    }
    return 1;
}

int BFS()
{
    memset(vis, 0, sizeof(vis));
    queue<Node> Q;
    now.x = startX;
    now.y = startY;
    now.leftTime = 6;
    now.cnt = 0;
    
    Q.push(now);
    
    while (!Q.empty()) {
        //獲取隊列首部元素
        now = Q.front();
        
        if (now.x == endX && now.y == endY) {
            return now.cnt;
        }
        
        for (int i = 0; i < 4; i++) {   //按照上、右、下、左的方向搜索,搜索方向可隨意,但是要保證四個方向都被搜索一遍
            nextStep.x = now.x + dir[i][0];
            nextStep.y = now.y + dir[i][1];
            nextStep.cnt = now.cnt + 1;
            nextStep.leftTime = now.leftTime - 1;
            
            if (isPracticable(nextStep)) {
                if (a[nextStep.x][nextStep.y] == 4) {
                    nextStep.leftTime = 6;             //當走到重設爆炸時間點的時候,把剩餘時間重新設置爲6
                    vis[nextStep.x][nextStep.y] = 1;   //把能夠重新設置爆炸時間的位置標記爲1,此處只能走一次
                }
                Q.push(nextStep);
            }
        }
        //把對首元素排出隊列
        Q.pop();
    }
    return -1;
}


int main(int argc, const char * argv[]) {
    
    int T;
   
    cin >> T;
    while (T--) {
        
        cin >> n >> m;
        memset(a, 0, sizeof(a));
        for (int i = 0; i < n; i++) {
            for (int j = 0; j < m; j++) {
                cin >> a[i][j];
                if (a[i][j] == 2) { //記錄開始點
                    startX = i;
                    startY = j;
                } else if (a[i][j] == 3) {  //記住結束點
                    endX = i;
                    endY = j;
                }
            }
        }
        cout << BFS() << endl;
    }
    return 0;
}






















發佈了78 篇原創文章 · 獲贊 12 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章