數數字

 數數字
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Appoint description: 

Description

Download as PDF

Trung is bored with his mathematics homeworks. He takes a piece of chalk and starts writing a sequence of consecutive integers starting with 1 to N(1 < N < 10000) . After that, he counts the number of times each digit (0 to 9) appears in the sequence. For example, with N = 13 , the sequence is: 

12345678910111213 

In this sequence, 0 appears once, 1 appears 6 times, 2 appears 2 times, 3 appears 3 times, and each digit from 4 to 9 appears once. After playing for a while, Trung gets bored again. He now wants to write a program to do this for him. Your task is to help him with writing this program. 

Input 

The input file consists of several data sets. The first line of the input file contains the number of data sets which is a positive integer and is not bigger than 20. The following lines describe the data sets. 

For each test case, there is one single line containing the number N . 

Output 

For each test case, write sequentially in one line the number of digit 0, 1,...9 separated by a space. 

Sample Input 

2 
3 
13

Sample Output 

0 1 1 1 0 0 0 0 0 0 
1 6 2 2 1 1 1 1 1 1


本體的解題思路是,定義一個string類型的vector向量容器,把數字轉換成字符串,然後把字符串添加到向量中,然後迭代vector向量,遍歷向量中的每一個string。定義一個整型數組,這裏採用了一個小技巧,整型數組的下標就分別對應着0~9的數,a[i]保存i出現的次數。


#include <vector>
#include <stdlib.h>
#include <string>
#include <string.h>
#include <stdio.h>
#include <iostream>
#include <sstream>
using namespace std;

int a[10];

//數字轉字符串
string num2str(int i)
{
    stringstream ss;
    ss<<i;
    return ss.str();
}

int main(int argc, const char * argv[]) {
    
    int n;
    vector<string> v;
    cin >> n;
    while (n--) {
        int m;
        cin >> m;
        string s;
        for (int i = 1; i <= m; i++) {
            s = num2str(i);  //數字轉字符串
            v.push_back(s);  //把轉換後得到的字符串放到string類型的向量中
        }
        vector<string>::iterator it;   //定義迭代器
        for (it = v.begin(); it != v.end(); it++) {
            s = *it;
            for (int i = 0; i < s.length(); i++) {
                a[s[i] - 48]++;
            }
        }
        for (int i = 0; i <= 9; i++) {
            if (i == 9) {
                cout << a[i] << endl;
            } else {
                cout << a[i] << " ";
            }
        }
        v.clear();  //清空向量
        memset(a, 0, sizeof(a));  //清空數組
    }

    return 0;
}























發佈了78 篇原創文章 · 獲贊 12 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章