[3951]:Coin Game

Problem Description
After hh has learned how to play Nim game, he begins to try another coin game which seems much easier.

這裏寫圖片描述

The game goes like this:
Two players start the game with a circle of n coins.
They take coins from the circle in turn and every time they could take 1~K continuous coins.
(imagining that ten coins numbered from 1 to 10 and K equal to 3, since 1 and 10 are continuous, you could take away the continuous 10 , 1 , 2 , but if 2 was taken away, you couldn’t take 1, 3, 4, because 1 and 3 aren’t continuous)
The player who takes the last coin wins the game.
Suppose that those two players always take the best moves and never make mistakes.
Your job is to find out who will definitely win the game.

Input
The first line is a number T(1<=T<=100), represents the number of case. The next T blocks follow each indicates a case.
Each case contains two integers N(3<=N<=109,1<=K<=10).

Output
For each case, output the number of case and the winner “first” or “second”.(as shown in the sample output)

Sample Input
2
3 1
3 2

Sample Output
Case 1: first
Case 2: second

#include<stdio.h>

int main(){
    int t;
    scanf("%d",&t);
    int n, k, cases = 0;
    while(t--){
        scanf("%d%d",&n, &k);
        printf("Case %d: ",++cases);
        if(k>=n){
           printf("first\n");
            continue;
        }
        if(k==1){
            if(n&1){
                printf("first\n");
            }
            else{
                 printf("second\n");
            }
        }else  { //當k>=2時,後手一定可以使下一個局面爲對稱的, 因此一定會贏
            printf("second\n");
        }
    }
    return 0;
}

這裏寫圖片描述

發佈了239 篇原創文章 · 獲贊 30 · 訪問量 12萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章