Uva10340(字符串搜索)

You have devised a new encryption technique which encodes a message by inserting between its characters
randomly generated strings in a clever way. Because of pending patent issues we will not discuss in
detail how the strings are generated and inserted into the original message. To validate your method,
however, it is necessary to write a program that checks if the message is really encoded in the final
string.
Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove
characters from t such that the concatenation of the remaining characters is s.

Input

The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII
characters separated by whitespace. Input is terminated by EOF.

Output

For each test case output, if s is a subsequence of t.

Sample Input

sequence subsequence

person compression

VERDI vivaVittorioEmanueleReDiItalia

caseDoesMatter CaseDoesMatter

Sample Output

Yes

No

Yes

No

題意:
給出兩個字符串s和t,判斷是否可以從t中刪除0個或者多個字符得到字符串s。

分析:
這裏給出兩種不同的做法。第二種做法可能更容易想到

1

/*將t中的每一個字符枚舉過去與s的第一個字符比較
如果比較成功了,就開始比較s中的第二個字符,
以此類推*/ 

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
char s[100000];
char t[100000];

int main(){
    while((scanf("%s",s)&&scanf("%s",t))!=EOF){
        int star = 0,lens = strlen(s),lent = strlen(t);
        for(int i = 0;i < lent;i++){
            if(t[i] == s[star]){
                star++;
            }
            if(star == lens){
                printf("Yes\n");
                break;
            }
        }
        if(star != lens)
            printf("No\n");
    }
    return 0;
}

2

#include <iostream>
#include <cstdio>
#include <cstring>
#define N 100010

using namespace std;

char str1[N], str2[N];
int s[N];

int main() {
    while ((scanf("%s", str1) &&scanf("%s", str2))!= EOF) {
        int m = 0;  //保存相同字符的個數  
        int len1 = strlen(str1);
        int len2 = strlen(str2);
        memset(s, 0, sizeof(s));
        if (len1 > len2)
            printf("No\n");
        else {
            int k = 0;
            for (int i = 0; i < len1; i++) {
                for (int j = k; j < len2; j++) {
                    if (str1[i] == str2[j]) { 
                        m++;   
                        k = j + 1;
                        break; 
                    }      
                }        
            }         
            if (m == len1) 
                printf("Yes\n");
            else
                printf("No\n"); 
        } 
    }
    return 0;
}
發佈了102 篇原創文章 · 獲贊 4 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章