Hduoj1040【水題】

/*As Easy As A+B
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 46241    Accepted Submission(s): 19757


Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. 
Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!

Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. 
T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers 
follow in the same line. 
It is guarantied that all integers are in the range of 32-int.

Output
For each case, print the sorting result, and one line one case.

Sample Input
2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

Sample Output
1 2 3
1 2 3 4 5 6 7 8 9

Author
lcy

Recommend
We have carefully selected several similar problems for you:  1062 1391 2673 1236 1056 
*/
#include<stdio.h>
#include<stdlib.h>
int a[1010];
int cmp(const void *a, const void *b)
{
	return *(int *)a - *(int *)b;
}
int main()
{
	int i, j, k, t, n;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%d", &n);
		for(i = 0; i < n; ++i)
			scanf("%d", &a[i]); 
		qsort(a, n, sizeof(a[0]), cmp);
		for(i = 0; i < n-1; ++i)
		printf("%d ", a[i]);
		printf("%d\n",a[n-1]);
	}
	return 0;
}
發佈了250 篇原創文章 · 獲贊 3 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章