Hduoj1039【水題】

/*Easier Done Than Said?
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 9975    Accepted Submission(s): 4849


Problem Description
Password security is a tricky thing. Users prefer simple passwords that are easy to remember (like buddy), but such passwords 
are often insecure. Some sites use random computer-generated passwords (like xvtpzyo), but users have a hard time remembering 
them and sometimes leave them written on notes stuck to their computer. One potential solution is to generate "pronounceable" 
passwords that are relatively secure but still easy to remember.

FnordCom is developing such a password generator. You work in the quality control department, and it's your job to test the 
generator and make sure that the passwords are acceptable. To be acceptable, a password must satisfy these three rules:

It must contain at least one vowel.

It cannot contain three consecutive vowels or three consecutive consonants.

It cannot contain two consecutive occurrences of the same letter, except for 'ee' or 'oo'.

(For the purposes of this problem, the vowels are 'a', 'e', 'i', 'o', and 'u'; all other letters are consonants.) Note that 
these rules are not perfect; there are many common/pronounceable words that are not acceptable.

Input
The input consists of one or more potential passwords, one per line, followed by a line containing only the word 'end' that 
signals the end of the file. Each password is at least one and at most twenty letters long and consists only of lowercase letters.

 
Output
For each password, output whether or not it is acceptable, using the precise format shown in the example.


Sample Input
a
tv
ptoui
bontres
zoggax
wiinq
eep
houctuh
end
 

Sample Output
<a> is acceptable.
<tv> is not acceptable.
<ptoui> is not acceptable.
<bontres> is not acceptable.
<zoggax> is not acceptable.
<wiinq> is not acceptable.
<eep> is acceptable.
<houctuh> is acceptable.
 

Source
Mid-Central USA 2000 

Recommend
We have carefully selected several similar problems for you:  1062 1043 1113 1161 1200 
*/
#include<stdio.h>
#include<string.h>
int main()
{
	char s[22];
	int i, j, k, ok1, ok2, ok3;
	while(gets(s) != NULL)
	{
		if(strcmp(s, "end") == 0)
		break;
		ok1 = 0;//標記第一個條件 
		ok2 = 0;//標記第二個條件 
		ok3 = 0;//標記第三個條件 
		int len = strlen(s), num1 = 0, num2 = 0;
		for(i = 0; i < len; ++i)
		{
			if(s[i] == 'a' || s[i] == 'e' || s[i] == 'i' || s[i] == 'o' || s[i] == 'u')
			{
				ok1 = 1;
				num1 ++;//元音+1 
				num2 = 0;//輔音清零 
			}
			else
			{
				num1 = 0;//元音清零 
				num2 ++;//輔音+1 
			}
			if(num1 >= 3 || num2 >= 3)
			ok2 = 1;
			if(s[i] == s[i-1] && s[i] != 'e' && s[i] != 'o')
			ok3 = 1;
		} 
		if(ok1 == 1 && ok2 == 0 && ok3 == 0)//如果滿足條件AC 
		printf("<%s> is acceptable.\n", s);
		else
		printf("<%s> is not acceptable.\n", s); 
	}
	return 0;
}


題意:給出一個字符串,要求滿足題目所給的三個條件,至少有一個元音,不能連續出現三個元音或三個輔音,不能連續出現2個一樣的字符除了“ee”和“oo”,其中aeiou爲元音其它全爲輔音,讓你判斷是否合格。

思路:純粹的模擬題。

發佈了250 篇原創文章 · 獲贊 3 · 訪問量 8萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章