數據結構實驗之鏈表七:單鏈表中重複元素的刪除 (sdut oj)


數據結構實驗之鏈表七:單鏈表中重複元素的刪除

Time Limit: 1000MS Memory Limit: 65536KB


Problem Description

按照數據輸入的相反順序(逆位序)建立一個單鏈表,並將單鏈表中重複的元素刪除(值相同的元素只保留最後輸入的一個)。


Input

第一行輸入元素個數 n (1 <= n <= 15);
第二行輸入 n 個整數,保證在 int 範圍內。


Output

第一行輸出初始鏈表元素個數;
第二行輸出按照逆位序所建立的初始鏈表;
第三行輸出刪除重複元素後的單鏈表元素個數;
第四行輸出刪除重複元素後的單鏈表。


Example Input

10
21 30 14 55 32 63 11 30 55 30


Example Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

Hint

Author

不得使用數組!







參考代碼



#include<stdio.h>
#include<stdlib.h>

struct node
{
    int data;
    struct node *next;
};

int main()
{
   int n;
   int i;
   scanf("%d",&n);
   struct node *head,*p,*q,*tail;
   head = (struct node *)malloc(sizeof(struct node));
   head->next = NULL;
   for( i = 0; i < n; i++ )
   {
      p = (struct node *)malloc(sizeof(struct node));
      scanf("%d",&p->data);
      p->next = head->next;
      head->next = p;
   }
   printf("%d\n",n);
   p = head->next;
   printf("%d",p->data);
   p = p->next;
   while(p)
   {
      printf(" %d",p->data);
      p = p->next;
   }
   printf("\n");
   p = head->next;
   while(p)
   {
        q = p;
        while(q->next)
        {
            if(q->next->data == p->data)
            {
                 tail = q->next;
                 q->next = tail->next;
                 free(tail);
                 n--;
            }
            else
            {
                q = q->next;
            }
        }
        p = p->next;
   }
   printf("%d\n",n);
   p = head->next;
   printf("%d",p->data);
   p = p->next;
   while(p)
   {
     printf(" %d",p->data);
     p = p->next;
   }
   printf("\n");
   return 0;
}


發佈了189 篇原創文章 · 獲贊 60 · 訪問量 17萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章