数据结构实验之链表七:单链表中重复元素的删除 (sdut oj)


数据结构实验之链表七:单链表中重复元素的删除

Time Limit: 1000MS Memory Limit: 65536KB


Problem Description

按照数据输入的相反顺序(逆位序)建立一个单链表,并将单链表中重复的元素删除(值相同的元素只保留最后输入的一个)。


Input

第一行输入元素个数 n (1 <= n <= 15);
第二行输入 n 个整数,保证在 int 范围内。


Output

第一行输出初始链表元素个数;
第二行输出按照逆位序所建立的初始链表;
第三行输出删除重复元素后的单链表元素个数;
第四行输出删除重复元素后的单链表。


Example Input

10
21 30 14 55 32 63 11 30 55 30


Example Output

10
30 55 30 11 63 32 55 14 30 21
7
30 55 11 63 32 14 21

Hint

Author

不得使用数组!







参考代码



#include<stdio.h>
#include<stdlib.h>

struct node
{
    int data;
    struct node *next;
};

int main()
{
   int n;
   int i;
   scanf("%d",&n);
   struct node *head,*p,*q,*tail;
   head = (struct node *)malloc(sizeof(struct node));
   head->next = NULL;
   for( i = 0; i < n; i++ )
   {
      p = (struct node *)malloc(sizeof(struct node));
      scanf("%d",&p->data);
      p->next = head->next;
      head->next = p;
   }
   printf("%d\n",n);
   p = head->next;
   printf("%d",p->data);
   p = p->next;
   while(p)
   {
      printf(" %d",p->data);
      p = p->next;
   }
   printf("\n");
   p = head->next;
   while(p)
   {
        q = p;
        while(q->next)
        {
            if(q->next->data == p->data)
            {
                 tail = q->next;
                 q->next = tail->next;
                 free(tail);
                 n--;
            }
            else
            {
                q = q->next;
            }
        }
        p = p->next;
   }
   printf("%d\n",n);
   p = head->next;
   printf("%d",p->data);
   p = p->next;
   while(p)
   {
     printf(" %d",p->data);
     p = p->next;
   }
   printf("\n");
   return 0;
}


发布了189 篇原创文章 · 获赞 60 · 访问量 17万+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章