POJ 1979 Red and Black 基礎性的DFS

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45

59

6

13


題意:以‘@’爲起始點,找出所有能到達的‘.’的個數,‘#’視爲牆,不可走。(‘@’本身也算‘.’)

思路:見代碼

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;

const int dir[4][2]={{1,0},{-1,0},{0,1},{0,-1}};
char map[30][30];
bool vis[30][30];
int w,h,sum;
int kx,ky;

void dfs(int kx,int ky)
{
    for(int i = 0; i < 4; i++)//搜索點的四個方向
    {
        int tx = kx + dir[i][0];
        int ty = ky + dir[i][1];
        if(!vis[tx][ty])//搜索到一個‘.’ , 進行記錄並以該點爲起始點繼續深搜
        {
            vis[tx][ty] = 1;//把搜索出來的‘.’記錄,防止重複計算
            sum++;
            dfs(tx,ty);
        }
    }
}

int main( )
{
    while(cin>>w>>h&&w&&h)
    {
        getchar();
        memset(vis,1,sizeof(vis));//把vis初始化爲1,可無需設置邊界,
        for(int i = 1; i <= h; i++)
        {
            for(int j = 1; j <= w; j++)
            {
                cin>>map[i][j];
                if('@'==map[i][j])
                {
                    kx = i;
                    ky = j;
                }
                else if('.'==map[i][j])
                {
                    vis[i][j]=0;//輸入的‘.’記錄爲0,意爲可走
                }
            }
            getchar();
        }
        sum = 1;
        dfs(kx,ky);
        cout<<sum<<endl;
    }
    return 0;
}



發佈了36 篇原創文章 · 獲贊 17 · 訪問量 4萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章