【2013南京現場賽】1001 hdu4802 GPA

Problem Description
In college, a student may take several courses. for each course i, he earns a certain credit (ci), and a mark ranging from A to F, which is comparable to a score (si), according to the following conversion table

The GPA is the weighted average score of all courses one student may take, if we treat the credit as the weight. In other words,

An additional treatment is taken for special cases. Some courses are based on “Pass/Not pass” policy, where stude nts earn a mark “P” for “Pass” and a mark “N” for “Not pass”. Such courses are not supposed to be considered in computation. These special courses must be ignored for computing the correct GPA.
Specially, if a student’s credit in GPA computation is 0, his/her GPA will be “0.00”.
 

Input
There are several test cases, please process till EOF.
Each test case starts with a line containing one integer N (1 <= N <= 1000), the number of courses. Then follows N lines, each consisting the credit and the mark of one course. Credit is a positive integer and less than 10.
 

Output
For each test case, print the GPA (rounded to two decimal places) as the answer.
 

Sample Input
5 2 B 3 D- 2 P 1 F 3 A 2 2 P 2 N 6 4 A 3 A 3 A 4 A 3 A 3 A
 

Sample Output
2.33 0.00 4.00
Hint
For the first test case: GPA =(3.0 * 2 + 1.0 * 3 + 0.0 * 1 + 4.0 * 3)/(2 + 3 + 1 + 3) = 2.33 For the second test case: because credit in GPA computation is 0(P/N in additional treatment), so his/her GPA is “0.00”.
 

題意:

求績點,公式如上圖。

思路:

水題。

//
//  main.cpp
//  A
//
//  Created by zc on 2017/9/9.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define ll long long
using namespace std;

int n;
int main(int argc, const char * argv[]) {
    while(~scanf("%d",&n))
    {
        double sum=0;
        double ans=0;
        for(int i=0;i<n;i++)
        {
            double t,p;
            char c[2];
            scanf("%lf%s",&t,c);
            if(c[0]=='N'||c[0]=='P')continue;
            if(c[0]=='A')
            {
                if(c[1]=='-')   p=3.7;
                else    p=4.0;
            }
            if(c[0]=='B')
            {
                if(c[1]=='+')   p=3.3;
                else if(c[1]=='-')  p=2.7;
                else    p=3.0;
            }
            if(c[0]=='C')
            {
                if(c[1]=='+')   p=2.3;
                else if(c[1]=='-')  p=1.7;
                else    p=2.0;
            }
            if(c[0]=='D')
            {
                if(c[1]=='-')   p=1.0;
                else    p=1.3;
            }
            if(c[0]=='F')   p=0.0;
            ans+=t*p;
            sum+=t;
        }
        if(sum==0)  ans=0;
        else    ans/=sum;
        printf("%.2f\n",ans);
    }
}

發佈了323 篇原創文章 · 獲贊 119 · 訪問量 21萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章