【2017廣西邀請賽】hdu 6186 CS Course

Problem Description
Little A has come to college and majored in Computer and Science.

Today he has learned bit-operations in Algorithm Lessons, and he got a problem as homework.

Here is the problem:

You are giving n non-negative integers a1,a2,,an, and some queries.

A query only contains a positive integer p, which means you 
are asked to answer the result of bit-operations (and, or, xor) of all the integers except ap.
 

Input
There are no more than 15 test cases. 

Each test case begins with two positive integers n and p
in a line, indicate the number of positive integers and the number of queries.

2n,q105

Then n non-negative integers a1,a2,,an follows in a line, 0ai109 for each i in range[1,n].

After that there are q positive integers p1,p2,,pqin q lines, 1pin for each i in range[1,q].
 

Output
For each query p, output three non-negative integers indicates the result of bit-operations(and, or, xor) of all non-negative integers except ap in a line.
 

Sample Input
3 3 1 1 1 1 2 3
 

Sample Output
1 1 0 1 1 0 1 1 0
 

題意:

求n個數,q個詢問,求除了第p個數的&,|,^。

思路:

異或的話直接求出所有的數的異或,然後異或詢問值。

與,或的話統計所有數每個位上的值。如果剩餘數在當前位上的值大於0,則或值加上這個位的值。

如果剩餘數早當前位上的值等於n-1,則與值加上這個位上的值。


//
//  main.cpp
//  1005
//
//  Created by zc on 2017/9/6.
//  Copyright © 2017年 zc. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<algorithm>
#define ll long long
using namespace std;
const int N=110000;
int n,q,b[N][40],c[40],p;
ll a[N];

int main(int argc, const char * argv[]) {
    while(~scanf("%d%d",&n,&q))
    {
        ll ans3=0;
        memset(b,0,sizeof(b));
        memset(c,0,sizeof(c));
        for(int i=1;i<=n;i++)
        {
            scanf("%lld",&a[i]);
            ans3^=a[i];
            for(int j=0;j<33;j++)
            {
                if(a[i]&(1LL<<j))   b[i][j]=1;
                c[j]+=b[i][j];
            }
        }
        for(int i=0;i<q;i++)
        {
            scanf("%d",&p);
            ll ans1=0,ans2=0;
            for(int j=0;j<33;j++)
            {
                if(c[j]-b[p][j]==n-1)   ans1+=(1LL<<j);
                if(c[j]-b[p][j]>0)  ans2+=(1LL<<j);
            }
            printf("%lld %lld %lld\n",ans1,ans2,ans3^a[p]);
        }
    }
}

發佈了323 篇原創文章 · 獲贊 119 · 訪問量 21萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章