Frogger

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 
Input
The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.
Output
For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.
Sample Input
2
0 0
3 4

3
17 4
19 4
18 5

0
Sample Output
Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

題意:小青蛙Freddy想去看小青蛙Fiona,他們中間有很多石頭,Freddy通過在石頭之間跳躍到達Fiona那裏,因爲Freddy比較懶,所以他希望每次跳的距離儘可能的短,而且,在每一條路中,他要跳的距離是所有距離最大的那個。比如第二個樣例,從第一個點到第二個點有兩條路線,1→2和1→3→2。1→2之間要跳2,1→3、3→2之間的距離都爲sqrt(2),所以我們選擇第二個方案,因爲第二個方案每次Freddy只要跳sqrt(2)。

思路:最短路的變形~

代碼1號:Floyd-Warshall

#include<stdio.h>//Floyd-Warshall
#include<math.h>
#include<algorithm>
using namespace std;
int main()
{
    int n,g=1;
    double x[250],y[250],a[250][250];
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
            scanf("%lf %lf",&x[i],&y[i]);
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                a[i][j]=a[j][i]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
        for(int k=0;k<n;k++)
            for(int i=0;i<n;i++)
                for(int j=0;j<n;j++)
                    a[i][j]=min(a[i][j],max(a[i][k],a[j][k]));
        printf("Scenario #%d\n",g++);
        printf("Frog Distance = %.3f\n\n",a[0][1]);
    }
    return 0;
}

代碼2號:Dijkstra

#include<stdio.h>//Dijkstra
#include<math.h>
#include<algorithm>
#define inf 0x3f3f3f
using namespace std;
int main()
{
    int n,g=1;
    double x[250],y[205],dis[250],a[250][250];
    int vis[250];
    while(~scanf("%d",&n),n)
    {
       for(int i=0;i<n;i++)
            scanf("%lf %lf",&x[i],&y[i]);
        for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
                a[i][j]=a[j][i]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
        for(int i=0;i<n;i++)
        {
            dis[i]=a[0][i];
            vis[i]=0;
        }
        vis[0]=1;
        for(int i=0;i<n-1;i++)
        {
            int k;
            double mi=inf;
            for(int j=0;j<n;j++)
            {
                if(vis[j]==0&&dis[j]<mi)
                {
                    mi=dis[j];
                    k=j;
                }
            }
            vis[k]=1;
            for(int j=0;j<n;j++)
                dis[j]=min(dis[j],max(dis[k],a[k][j]));
        }
        printf("Scenario #%d\n",g++);
        printf("Frog Distance = %.3f\n\n",dis[1]);
    }
    return 0;
}

代碼3號:spfa

沒有完全掌握~

然後spfa()那一段是別人的代碼~

點擊打開原代碼鏈接

#include<stdio.h>
#include<math.h>
#include<queue>
#include<algorithm>
#define inf 0x3f3f3f
using namespace std;
int n,g=1,vis[250];
double x[250],y[250],dis[250],a[250][250];
void spfa()
{
    queue<int>q;
    int i,j;
    for(i=1; i<n; i++)
    {
        dis[i]=inf;
        vis[i]=0;
    }
    dis[0]=0;
    q.push(0);
    vis[0]=1;
    while(!q.empty())
    {
        i=q.front();
        q.pop();
        vis[i]=0;
        for(j=0; j<n; j++)
        {
            if(dis[j]>max(dis[i],a[i][j]))
            {
                dis[j]=max(dis[i],a[i][j]);
                if(vis[j]==0)
                {
                    q.push(j);
                    vis[j]=1;
                }
            }
        }
    }
}
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0; i<n; i++)
            scanf("%lf %lf",&x[i],&y[i]);
        for(int i=0; i<n; i++)
            for(int j=0; j<n; j++)
                a[i][j]=a[j][i]=sqrt((x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]));
        spfa();
        printf("Scenario #%d\n",g++);
        printf("Frog Distance = %.3f\n\n",dis[1]);
    }
    return 0;
}
發佈了78 篇原創文章 · 獲贊 4 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章