GCD hdu 2588

Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
3 1 1 10 2 10000 72
 

Sample Output
1 6 260
 

Source

題意:給出兩個整數n和m,求使gcd(x,n)>=m的x的個數,

思路:假設i=x/gcd(x,n),j=n/gcd(x,n),可以看出i、j互質。我們要求的就是i、j的總共有多少對。也就是說求與j小於j並且與j互質的數的個數。

拿樣例來說:

第一個中,1的約數只有1,ans=euler(1/1);

第二個樣例中,10的約數有1、2、5、10,ans=euler(10/2)+euler(10/5)+euler(10/10);

第三個樣例就不說了,太多了。

最開始直接枚舉n的約數的話就超了,所以選擇sqrt(n)內枚舉,找到一個 i 使n%i==0就相當於找到2個n的約數了。

不要問我爲什麼不用歐拉篩法,因爲n的取值範圍太大·······

代碼:

#include<stdio.h>
#include<math.h>
int euler(int n)
{
    int res=n;
    for(int i=2; i<=n; i++)
    {
        if(n%i==0)
        {
            res=res/i*(i-1);
            while(n%i==0)
                n/=i;
        }
    }
    if(n>1)
        res=res/n*(n-1);
    return res ;
}
int main()
{
    int t,n,m,ans;
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        scanf("%d %d",&n,&m);
        for(int i=1; i<=sqrt(n); i++)//寫成sqrt(n)的話是爲了不超時~ 就比如10=2*5,我們知道一個數是2了,那5肯定也知道了,就可以少循環一點了
        {
            if(n%i==0)
            {
                if(i>=m)
                    ans+=euler(n/i);
                if(n/i>=m&&i*i!=n)
                    ans+=euler(i);
            }
        }
        printf("%d\n",ans);
    }
    return 0;
}

發佈了78 篇原創文章 · 獲贊 4 · 訪問量 1萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章