1002,大數求和

Problem Description

I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input

The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output

For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input

2
1 2
112233445566778899 998877665544332211

Sample Output

Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110


思路分析:
共分三步進行處理,1,兩數組各自從最高下標相加並存如新數組中,直到其中一個到達下標爲0;
2,將下標沒到達0的數組加到新數組中;
3,判斷最後是否還有進位,若有加到新數組中。


#include<stdio.h>
#include<string.h>

int main()
{
    int t;
    int i,j,k,m,l1,l2;
    char a[1005],b[1005];
    int c[1005];

    scanf ("%d",&t);

    int x=1;

    while (t--)
    {

        scanf ("%s%s",a,b);

        int m = 0;
        l1 = strlen(a);
        l2 = strlen(b);

        for (i=l1-1,j=l2-1,k=0; i>=0 && j>=0; i--,j--)
        {
            m = a[i]-48+b[j]-48+m;
            c[k++] = m%10;
            m /= 10;
        }

        if (k == l1)
        {
            while (j>=0)
            {
                m = b[j--]-48+m;
                c[k++] = m%10;
                m = m/10;
            }
        }
        else
        {
            while (i>=0)
            {
                m = a[i--]-48+m;
                c[k++] = m%10;
                m = m/10;
            }
        }

        if (m != 0)
        {
            c[k++] = m;
        }

        printf ("Case %d:\n",x++);
        printf ("%s + %s = ",a,b);

        for (i=k-1; i>=0; i--)
        {
            printf ("%d",c[i]);
        }

        printf ("\n");

        if (t)
            printf ("\n");

    }
    return 0;
}
發佈了41 篇原創文章 · 獲贊 0 · 訪問量 8091
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章