1005

Description

A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).

Input

The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output

For each test case, print the value of f(n) on a single line.
Sample Input

1 1 3
1 2 10
0 0 0
Sample Output

2
5


這題不能直接按公式用遞歸來求,因爲n最大可以達到100,000,000,會棧溢出
所以要找規律
前兩個等於1,所以後面如果有兩個連着的1出現,那就是出現週期了.

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
    int a,b,n;
    while (scanf ("%d%d%d",&a,&b,&n) && (a+b+n))
    {
        int i,j;
        int f[100]={0,1,1};

        for (i=3; i<100; i++)
        {
            f[i] = (a*f[i-1] + b*f[i-2]) % 7;
       //如果有兩個連着 =1,則後面的全部和前面相同,即出現了週期  
      //這時就沒必要再進行下去了,跳出循環, i-2爲週期   
            if (f[i] == 1 && f[i-1] == 1)
                break;
        }

        n = n%(i-2);

        f[0] = f[i-2];  /* 把n對週期求模,當n %(i-2)==0時,此時本來應該取f[i-2]的,所以把f[0]=f[i-2]*/

        printf ("%d\n",f[n]);
    }
    return 0;
}
發佈了41 篇原創文章 · 獲贊 0 · 訪問量 8092
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章