hdu 1020

Encoding

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 12989    Accepted Submission(s): 5502


Problem Description
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.
 

Input
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.
 

Output
For each test case, output the encoded string in a line.
 

Sample Input
2 ABC ABBCCC
 

Sample Output
ABC A2B3C
 


#include<string.h>
#include<stdio.h>
int main ()
{
  int t ;
  char str[10005];
 while( scanf("%d" , &t ) != EOF )
 {
  while( t-- )
  {


      scanf("%s" , str);
      int len = strlen ( str );
      for( int i = 0 ; i < len ; i++  )
      {
          int hh = 1 ;
          for( int j = i+1 ; j < len ; j++ )
             if( str[i] == str[j] )hh++;
             else break;
          if( hh > 1 )
            printf("%d%c", hh , str[i] );
          else
            printf("%c" , str[i]);
          
          i +=(hh-1);//從下一個不重複的字母開始
      }
      puts("");
  }
 }
  return 0;
}
發佈了171 篇原創文章 · 獲贊 9 · 訪問量 9萬+
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章