hdu2103

Family planning

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7311    Accepted Submission(s): 1897


Problem Description
As far as we known,there are so many people in this world,expecially in china.But many people like LJ always insist on that more people more power.And he often says he will burn as much babies as he could.Unfortunatly,the president XiaoHu already found LJ's extreme mind,so he have to publish a policy to control the population from keep on growing.According the fact that there are much more men than women,and some parents are rich and well educated,so the president XiaoHu made a family planning policy:
According to every parents conditions to establish a number M which means that parents can born M children at most.But once borned a boy them can't born other babies any more.If anyone break the policy will punished for 10000RMB for the first time ,and twice for the next time.For example,if LJ only allowed to born 3 babies at most,but his first baby is a boy ,but he keep on borning another 3 babies, so he will be punished for 70000RMB(10000+20000+40000) totaly.
 

Input
The first line of the input contains an integer T(1 <= T <= 100) which means the number of test cases.In every case first input two integers M(0<=M<=30) and N(0<=N<=30),N represent the number of babies a couple borned,then in the follow line are N binary numbers,0 represent girl,and 1 represent boy.
 

Output
Foreach test case you should output the total money a couple have to pay for their babies.
 

Sample Input
2 2 5 0 0 1 1 1 2 2 0 0
 

Sample Output
70000 RMB 0 RMB
 
这道题,我觉得是一道水题,不过,还是需要考虑一些东西的。当法定生子数与实际生子数的大小关系。同时还要考虑当法定生子数为零的情况。还要考虑生第一个儿子是第几个生的(假如有的话)。

思路:从题意可以知道,当生了儿子后,以后所生的孩子都是要罚款的。那我们不妨把第一个儿子的位置设为罚款点。然后从罚款点一直罚到实际生子数。不过,当n为0的时候,要独立考虑。
这道题我WA了几次,因为我总把1看成女孩,还有就是一个小问题
错误代码:
#include<stdio.h>
#include<>
int main()
{
    int t,n,m,i,x,p=1;
    scanf("%d",&t);
    while(t--)
    {
        int first=1,flag=0;
        scanf("%d%d",&m,&n);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&x);
            if(first&&x)//  0是女孩,1是男孩。。
            {
                first=0;
                flag=i;
            }
        }
        __int64 j=10000,sum=0;    // j和sum都要用__int64 否则WA
        if(flag && flag<=m)
        {
            for(i=flag+1;i<=n;i++)
            {
                sum+=j;
                j*=2;
            }
        }
        else
        {
            for(i=m+1;i<=n;i++)
            {
                sum+=j;
                j*=2;
            }
        }
        printf("%I64d RMB\n",sum);
    }
    return 0;
}

正确代码:
#include<stdio.h>
#include<string.h>
int main()
{
    int t,n,m,i,x,p=1;
    __int64 j,sum;
    scanf("%d",&t);
    while(t--)
    {
        int first=1,flag=0;
        scanf("%d%d",&m,&n);
        for(i=1;i<=n;i++)
        {
            scanf("%d",&x);
            if(first&&x)  //  0是女孩,1是男孩。。
            {
                first=0;
                flag=i;
            }
        }
        j=10000,sum=0;    // j和sum都要用__int64 否则WA
        if(flag && flag<=m)
        {
            for(i=flag+1;i<=n;i++)
            {
                sum+=j;
                j*=2;
            }
        }
        else
        {
            for(i=m+1;i<=n;i++)
            {
                sum+=j;
                j*=2;
            }
        }
        printf("%I64d RMB\n",sum);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章