HDU 1034 Candy Sharing Game

Candy Sharing Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6052    Accepted Submission(s): 3674


Problem Description
A number of students sit in a circle facing their teacher in the center. Each student initially has an even number of pieces of candy. When the teacher blows a whistle, each student simultaneously gives half of his or her candy to the neighbor on the right. Any student, who ends up with an odd number of pieces of candy, is given another piece by the teacher. The game ends when all students have the same number of pieces of candy.
Write a program which determines the number of times the teacher blows the whistle and the final number of pieces of candy for each student from the amount of candy each child starts with.
 

Input
The input may describe more than one game. For each game, the input begins with the number N of students, followed by N (even) candy counts for the children counter-clockwise around the circle. The input ends with a student count of 0. Each input number is on a line by itself.
 

Output
For each game, output the number of rounds of the game followed by the amount of candy each child ends up with, both on one line.
 

Sample Input
6 36 2 2 2 2 2 11 22 20 18 16 14 12 10 8 6 4 2 4 2 4 6 8 0
 

Sample Output
15 14 17 22 4 8
Hint
The game ends in a finite number of steps because: 1. The maximum candy count can never increase. 2. The minimum candy count can never decrease. 3. No one with more than the minimum amount will ever decrease to the minimum. 4. If the maximum and minimum candy count are not the same, at least one student with the minimum amount must have their count increase.
 

Source


一羣學生圍着老師坐,每個學生手裏有一定數量的糖,老師吹口哨開始每個學生將自己糖數的一半分給自己右邊的同學,同時如果同學手中的糖數爲奇數,老師將會再分給他一顆糖,問經過多少次循環之後每個同學手中的糖數會是相等的。輸出最後相等時候的糖數以及老師吹口哨的次數,也就是循環的次數。

#include<iostream>
using namespace std;

bool judge(int a[],int N){
	int b=a[1];
	for(int i=2;i<=N;i++)
	{
		if(b!=a[i])return false;
	}
	return true;
}

int main(){
	int N;
	while(cin>>N&&N){
		int *a = new int[N+2];
		int step=0;
		for(int i=1;i<=N;i++)cin>>a[i];
		while(!judge(a,N))
		{
			a[0]=a[N];
			for(int i=N;i>0;i--)     //從右端開始
			{
				a[i]=a[i-1]/2+a[i]/2;
				if(a[i]&1)++a[i];   //按位與,判斷是否爲奇數
			}
			step++;
		}
		cout<<step<<" "<<a[1]<<endl;
	}
	return 0;
} 


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章