HDU 1033 Edge

Edge

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3368    Accepted Submission(s): 2128


Problem Description
For products that are wrapped in small packings it is necessary that the sheet of paper containing the directions for use is folded until its size becomes small enough. We assume that a sheet of paper is rectangular and only folded along lines parallel to its initially shorter edge. The act of folding along such a line, however, can be performed in two directions: either the surface on the top of the sheet is brought together, or the surface on its bottom. In both cases the two parts of the rectangle that are separated by the folding line are laid together neatly and we ignore any differences in thickness of the resulting folded sheet.
After several such folding steps have been performed we may unfold the sheet again and take a look at its longer edge holding the sheet so that it appears as a one-dimensional curve, actually a concatenation of line segments. If we move along this curve in a fixed direction we can classify every place where the sheet was folded as either type A meaning a clockwise turn or type V meaning a counter-clockwise turn. Given such a sequence of classifications, produce a drawing of the longer edge of the sheet assuming 90 degree turns at equidistant places.
 

Input
The input contains several test cases, each on a separate line. Each line contains a nonempty string of characters A and V describing the longer edge of the sheet. You may assume that the length of the string is less than 200. The input file terminates immediately after the last test case.
 

Output
For each test case generate a PostScript drawing of the edge with commands placed on separate lines. Start every drawing at the coordinates (300, 420) with the command "300 420 moveto". The first turn occurs at (310, 420) using the command "310 420 lineto". Continue with clockwise or counter-clockwise turns according to the input string, using a sequence of "x y lineto" commands with the appropriate coordinates. The turning points are separated at a distance of 10 units. Do not forget the end point of the edge and finish each test case by the commands stroke and showpage.

You may display such drawings with the gv PostScript interpreter, optionally after a conversion using the ps2ps utility.


 

Sample Input
V AVV
 

Sample Output
300 420 moveto 310 420 lineto 310 430 lineto stroke showpage 300 420 moveto 310 420 lineto 310 410 lineto 320 410 lineto 320 420 lineto stroke showpage
 

Source

題目很長,說了一大堆大概意思就是A表示每次都是右拐,V是左拐,然後就是打印出每次的路徑輸出即可

#include<iostream>
#include<string>
using namespace std;
int main()
{
	string s;
	while(cin>>s)
	{
		cout<<"300 420 moveto"<<endl<<"310 420 lineto"<<endl; //不管是哪個方位,起初都要先向前走一步
		int first=310,second=420;
		char face='E';  //用face來表示此時正面向的是哪個方位 ,起初是面向East方向
		for(int i=0;i<s.length();i++)
		{
			if(s[i]=='A')
			{
				if(face=='E') {second-=10;face='S';}  //在每次拐彎之後就記錄下這個時候面向哪個方向
				else if(face=='N'){first+=10;face='E';}
				else if(face=='S'){first-=10;face='W';}
				else {second+=10;face='N';}
				cout<<first<<" "<<second<<" lineto"<<endl;
			}else
			{
				if(face=='E') {second+=10;face='N';}
				else if(face=='N'){first-=10;face='W';}
				else if(face=='S'){first+=10;face='E';}
				else {second-=10;face='S';}
				cout<<first<<" "<<second<<" lineto"<<endl;
			}
		}
		cout<<"stroke"<<endl<<"showpage"<<endl;
	}
} 




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章