lucas定理求大數組合數取模

Saving Beans

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 5520    Accepted Submission(s): 2208


Problem Description
Although winter is far away, squirrels have to work day and night to save beans. They need plenty of food to get through those long cold days. After some time the squirrel family thinks that they have to solve a problem. They suppose that they will save beans in n different trees. However, since the food is not sufficient nowadays, they will get no more than m beans. They want to know that how many ways there are to save no more than m beans (they are the same) in n trees.

Now they turn to you for help, you should give them the answer. The result may be extremely huge; you should output the result modulo p, because squirrels can’t recognize large numbers.
 

Input
The first line contains one integer T, means the number of cases.

Then followed T lines, each line contains three integers n, m, p, means that squirrels will save no more than m same beans in n different trees, 1 <= n, m <= 1000000000, 1 < p < 100000 and p is guaranteed to be a prime.
 

Output
You should output the answer modulo p.
 

Sample Input
2 1 2 5 2 1 5
 

Sample Output
3 3
Hint
Hint For sample 1, squirrels will put no more than 2 beans in one tree. Since trees are different, we can label them as 1, 2 … and so on. The 3 ways are: put no beans, put 1 bean in tree 1 and put 2 beans in tree 1. For sample 2, the 3 ways are: put no beans, put 1 bean in tree 1 and put 1 bean in tree 2.
 

Source

2009 Multi-University Training Contest 13 - Host by HIT

首先這個文藝需要推導一番,你需要知道組合數學裏面的隔板法,然後還要知道一些組合數學的公式,方可推導出此題的公式,然後就可以愉快的套lucas的模板了,https://baike.baidu.com/item/%E9%9A%94%E6%9D%BF%E6%B3%95/3902458?fr=aladdin(這個是隔板法百度的鏈接,感覺 講的挺好的,就是這個問題額的模型)然後你就可以推導出上面那個式子,具體上面那個式子是怎麼得到下面的那個式子呢,1<=k<=n-1有C(n,k)=C(n-1,k)+C(n-1,k-1)有這樣子的一個式子,這個式子手動就可以推導出來是正確的,另外這個問題最後還特意說模數是一個prime,這個感覺就是在暗示用lucas的吧。

代碼:

#include<algorithm>
#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn= 100010;
long long fac[maxn];
long long mult_mod(long long a,long long b,long long mod)
{
    a%=mod;
    b%=mod;
    long long ret=0;
    while(b)
    {
        if(b&1)
        {
            ret+=a;
            ret%=mod;

        }
        a<<=1;
        if(a>=mod)
            a%=mod;
        b>>=1;
    }
    return ret;
}
long long pow_mod(long long x,long long n,long long mod)
{
    if(n==1)
        return x%mod;
    x%=mod;
    long long tmp=x;
    long long ret=1;
    while(n)
    {
        if(n&1)
            ret=mult_mod(ret,tmp,mod);
        tmp=mult_mod(tmp,tmp,mod);
        n>>=1;
    }
    return ret;
}
long long C(long long n,long long k,long long mod)
{
    if(n<k||n<0||k<0)
        return 0;
    return fac[n]*pow_mod(fac[n-k]*fac[k]%mod,mod-2,mod)%mod;

}
long long lucas(long long a,long long b,long long mod)
{
    if(b==0)
        return 1;
    return lucas(a/mod,b/mod,mod)*C(a%mod,b%mod,mod)%mod;

}
void init(long long mod)
{
    fac[0]=fac[1]=1;
    for(int i=2; i<=mod; i++)
    {
        fac[i]=fac[i-1]*i%mod;
    }
}
int main()
{
    long long n,m,k;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d",&n,&m,&k);
        init(k);
        printf("%I64d\n",lucas(n+m,m,k));
    }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章