HDOJ 1757 A Simple Math Problem

A Simple Math Problem

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4334    Accepted Submission(s): 2605


Problem Description
Lele now is thinking about a simple function f(x).

If x < 10 f(x) = x.
If x >= 10 f(x) = a0 * f(x-1) + a1 * f(x-2) + a2 * f(x-3) + …… + a9 * f(x-10);
And ai(0<=i<=9) can only be 0 or 1 .

Now, I will give a0 ~ a9 and two positive integers k and m ,and could you help Lele to caculate f(k)%m.
 

Input
The problem contains mutiple test cases.Please process to the end of file.
In each case, there will be two lines.
In the first line , there are two positive integers k and m. ( k<2*10^9 , m < 10^5 )
In the second line , there are ten integers represent a0 ~ a9.
 

Output
For each case, output f(k) % m in one line.
 

Sample Input
10 9999 1 1 1 1 1 1 1 1 1 1 20 500 1 0 1 0 1 0 1 0 1 0
 

Sample Output
45

104

矩陣快速冪。

代碼:

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int MOD;
struct mat
{
    int a[10][10];
};
mat mat_mul(mat x,mat y)
{
    mat res;
    memset(res.a,0,sizeof(res.a));
    for(int i=0; i<10; i++)
    {
        for(int j=0; j<10; j++)
        {
            for(int k=0; k<10; k++)
            {
                if(x.a[i][k]&&y.a[k][j])
                {
                    res.a[i][j]=(res.a[i][j]+x.a[i][k]*y.a[k][j])%MOD;
                }
            }
        }
    }
    return res;
}
mat mat_fast(mat c,int N)
{
    mat res;
    memset(res.a,0,sizeof(res.a));
    for(int i=0; i<10; i++)
    {
        res.a[i][i]=1;
    }
    while(N!=0)
    {
        if(N&1)
        {
            res=mat_mul(res,c);
        }
        c=mat_mul(c,c);
        N=N>>1;
    }
    //printf("%I64d\n",res.a[0][1]);
    return res;
}
int main()
{
    int k;
    while(~scanf("%d%d",&k,&MOD))
    {
        if(k<10)
        {
            printf("%d\n",k);
            continue;
        }
        int x;mat c,res;
        memset(c.a,0,sizeof(c.a));
        memset(res.a,0,sizeof(res.a));
        for(int i=0; i<10; i++)
        {
            scanf("%d",&x);
            c.a[0][i]=x;
            res.a[i][0]=9-i;
        }
        for(int i=1; i<10; i++)
        {
            c.a[i][i-1]=1;
        }
            mat ans=mat_mul(mat_fast(c,k-9),res);
            printf("%d\n",ans.a[0][0]%MOD);
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章