poj 2362 Square

Square
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 19347   Accepted: 6712

Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5

Sample Output

yes
no
yes

Source



1011的基礎版
這道題就是說把輸入的幾根給定長度木棒拼成一個正方形,如果能拼成功則輸出yes,否則輸出no。
這題是用dfs外加剪枝解決的。
可以根據完成三條邊的搜索就成立完成一次剪枝,總長被4整除第二次剪枝。。。
ac代碼如下:
#include <cstdio>/*Problem:2362 User:motefly Memory: 724K Time: 329MS Language: G++ Result: Accepted*/
#include <iostream>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN =10000;
int t,m,a[MAXN+10],xba;bool vis[MAXN+10];

int cmp(const void* a,const void* b)
{
    return *(int*)b-*(int*)a;
}

bool dfs(int s,bool *vis,int len,int num)
{
    if(num==3)
    return true;
    for(int i=s;i<m;i++)
    {
        if(vis[i])
        continue;
        vis[i]=true;
        if(len+a[i]<xba)
        {
            if(dfs(i,vis,len+a[i],num))
                return true;
        }
        else if(len+a[i]==xba)
           if(dfs(0,vis,0,num+1))
                return true;

        vis[i]=false;
    }
    return false;
}


int main()
{
    scanf("%d",&t);
    while(t--)
    {
        int sum=0;
        scanf("%d",&m);
        memset(a,0,sizeof(a));
        memset(vis,0,sizeof(vis));
        for(int i=0;i<m;i++)
            {
                scanf("%d",&a[i]);
                sum+=a[i];
            }
        if(m<4||sum%4)
            {
                cout<<"no"<<endl;
                continue;
            }
        else {qsort(a,m,sizeof(int),cmp);
        xba=sum/4;
    dfs(0,vis,0,0) ? (cout<<"yes"<<endl) : (cout<<"no"<<endl);
    }}
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章