King Arthur's Knights —— 結題報告!

http://acm.hdu.edu.cn/showproblem.php?pid=4337

King Arthur's Knights

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Special Judge

Problem Description
I am the bone of my sword. Steel is my body, and the fire is my blood.
- from Fate / Stay Night
You must have known the legend of King Arthur and his knights of the round table. The round table has no head, implying that everyone has equal status. Some knights are close friends with each other, so they prefer to sit next to each other.

Given the relationship of these knights, the King Arthur request you to find an arrangement such that, for every knight, his two adjacent knights are both his close friends. And you should note that because the knights are very united, everyone has at least half of the group as his close friends. More specifically speaking, if there are N knights in total, every knight has at least (N + 1) / 2 other knights as his close friends.

Input
The first line of each test case contains two integers N (3 <= N <= 150) and M, indicating that there are N knights and M relationships in total. Then M lines followed, each of which contains two integers ai and bi (1 <= ai, bi <= n, ai != bi), indicating that knight ai and knight bi are close friends.

Output
For each test case, output one line containing N integers X1, X2, ..., XN separated by spaces, which indicating an round table arrangement. Please note that XN and X1 are also considered adjacent. The answer may be not unique, and any correct answer will be OK. If there is no solution exists, just output "no solution".

Sample Input
3 3 1 2 2 3 1 3 4 4 1 4 2 4 2 3 1 3

Sample Output
1 2 3 1 4 2 3

Source

Recommend
zhoujiaqi2010

 

其他大牛的結題報告,我到略看了下。

http://www.cnblogs.com/jiai/archive/2012/08/03/2621040.html

http://blog.sina.com.cn/s/blog_6ffc3bde01012lyj.html
看了大牛的結題報告,說是深搜,再略看了下,就自己敲了下。敲的途中,沒看正確 的 結題報告,一路敲下來。樣例過了,提交了幾次,也wa 了幾次,原因也找到了。


題目會做,就覺得不過如此,一個深搜,根本是是H圖。

happy中!

加油↖(^ω^)↗!

 

//King Arthur's Knights
#include <cstdio>
#include <cstring>
#include <vector>
#include <iostream>
#include <cstdio>
using namespace std;

vector <vector <int> >g;

int a[200];
int pos;
int n, m;
bool use[200];

void init()
{
    g.clear();
    g.resize(n + 1);
    pos = 0;
    memset(use, false, sizeof (use));
}

bool f(int x)
{
    if (pos == n)
    {
        for (int j = g[1].size() - 1; j >= 0; j--)
            if (g[1][j] == x)
                return true;
        return false;
    }
    else
    {
        for (int j = g[x].size() - 1; j >= 0; j--)
        {
            if ( !use[ g[x][j] ])
            {
                use[ g[x][j]] = true;
                a[pos++] =  g[x][j];

                if (f( g[x][j]  ))
                    return true;
                else
                {
                    use[ g[x][j]] = false;
                    pos--;
                }
            }
        }
        return false;
    }


}

int main()
{
    while (cin >> n >> m)
    {
        init();
        {
            int u, v;
            for (int j = 0; j < m; j++)
            {
                scanf("%d%d", &u, &v);
                g[u].push_back(v);
                g[v].push_back(u);
            }

            pos = 1;
            use[1] = true;
            if (f(1))
            {
                printf("1");
                for(int j = 1; j < n; j++)
                    printf(" %d", a[j]);
                printf("\n");
            }
            else
                printf("no solution\n");
        }
    }

    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章