ZOJ 2971 Give Me the Number

Numbers in English are written down in the following way (only numbers less than 109 are considered). Number abc,def,ghi is written as "[abc] million [def] thousand [ghi]". Here "[xyz] " means the written down number xyz .

In the written down number the part "[abc] million" is omitted if abc = 0 , "[def] thousand" is omitted if def = 0 , and "[ghi] " is omitted if ghi = 0 . If the whole number is equal to 0 it is written down as "zero". Note that words "million" and "thousand" are singular even if the number of millions or thousands respectively is greater than one.

Numbers under one thousand are written down in the following way. The number xyz is written as "[x] hundred and [yz] ”. ( If yz = 0 it should be only “[x] hundred”. Otherwise if y = 0 it should be only “[x] hundred and [z]”.) Here "[x] hundred and" is omitted if x = 0 . Note that "hundred" is also always singular.

Numbers under 20 are written down as "zero", "one", "two", "three", "four", "five", "six", "seven", "eight", "nine", "ten", "eleven", "twelve", "thirteen", "fourteen", "fifteen", "sixteen", "seventeen", "eighteen", and "nineteen" respectively. Numbers from 20 to 99 are written down in the following way. Number xy is written as "[x0][y] ", and numbers divisible by ten are written as "twenty", "thirty", "forty", "fifty", "sixty", "seventy", "eighty", and "ninety" respectively.

For example, number 987,654,312 is written down as "nine hundred and eighty seven million six hundred and fifty four thousand three hundred and twelve", number 100,000,037 as "one hundred million thirty seven", number 1,000 as "one thousand". Note that "one" is never omitted for millions, thousands and hundreds.

Give you the written down words of a number, please give out the original number.

Input

Standard input will contain multiple test cases. The first line of the input is a single integer T (1 <= T <= 1900) which is the number of test cases. It will be followed by T consecutive test cases.

Each test case contains only one line consisting of a sequence of English words representing a number.

Output

For each line of the English words output the corresponding integer in a single line. You can assume that the integer is smaller than 109.

Sample Input

3
one
eleven
one hundred and two

Sample Output

1
11
102

字母轉數字

#include<stdio.h>
#include<string.h>
#include<math.h>
char str[28][20]= {"zero","one","two","three","four","five","six","seven","eight","nine","ten","eleven","twelve","thirteen","fourteen","fifteen","sixteen","seventeen","eighteen","nineteen","twenty","thirty","forty","fifty","sixty","seventy","eighty","ninety"};
int a[28]= {0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15,16,17,18,19,20,30,40,50,60,70,80,90};
int main()
{
    char b[200],*p,*q;
    int T,i,sum1,sum2,l,j;
    scanf("%d",&T);
    getchar();
    while(T--)
    {
        gets(b);
        l=strlen(b);
        p=b;q=b;
        sum1=sum2=0;
        for(i=0; i<=l; i++)
        {
            if(b[i]==' ')
                b[i]='\0';
            if(b[i]=='\0'&&b[i+1]!=' ')
            {
                for(j=0; j<28; j++)
                {
                    if(strcmp(p,str[j])==0)
                    {
                        sum1+=a[j];
                        break;
                    }
                }
                if(j=28)
                {
                    if(strcmp(p,"hundred")==0)
                        sum1*=100;
                    else if(strcmp(p,"million")==0)
                    {
                        sum1*=1000000;
                        sum2=sum1;
                        sum1=0;
                    }
                    else if(strcmp(p,"thousand")==0)
                    {
                        sum1*=1000;
                        sum2+=sum1;
                        sum1=0;
                    }
                }
                p=q+i+1;
            }
        }
        if(sum2==0)
            printf("%d\n",sum1);
        else
            printf("%d\n",sum2+sum1);
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章