QAQ……queue Q,这操作困扰了我很久

首先,分享一下我悲剧的经历。听说DFS容易出各种各样莫(ren)名(pin)其(bu)妙(hao)的错,然后BFS各种好,然后就去看了BFS(这就是我悲剧的开端)。先是在网上看别人的代码,然后看到一个:

queue<node> Q

这样的写法,很迷,还特地把代码打下来,研究了两个星期。

然后……

一无所获,之后就去咨询了学长,然后学长告诉我,这个大概是之前定义了结构体。这个时候才发现我看的代码是核心代码(╯‵□′)╯︵┻━┻  (╯‵□′)╯︵┻━┻。

然后分享一下题目吧

Dungeon Master     

               You are trapped in a 3D dungeon and need to find the quickest way out! The dungeon is composed of unit cubes which may or may not be filled with rock. It takes one minute to move one unit north, south, east, west, up or down. You cannot move diagonally and the maze is surrounded by solid rock on all sides.

Is an escape possible? If yes, how long will it take?

Input
The input consists of a number of dungeons. Each dungeon description starts with a line containing three integers L, R and C (all limited to 30 in size).
L is the number of levels making up the dungeon.
R and C are the number of rows and columns making up the plan of each level.
Then there will follow L blocks of R lines each containing C characters. Each character describes one cell of the dungeon. A cell full of rock is indicated by a '#' and empty cells are represented by a '.'. Your starting position is indicated by 'S' and the exit by the letter 'E'. There's a single blank line after each level. Input is terminated by three zeroes for L, R and C.
Output
Each maze generates one line of output. If it is possible to reach the exit, print a line of the form
Escaped in x minute(s).

where x is replaced by the shortest time it takes to escape.
If it is not possible to escape, print the line

Trapped!
Sample Input
3 4 5
S....
.###.
.##..
###.#

#####
#####
##.##
##...

#####
#####
#.###
####E

1 3 3
S##
#E#
###

0 0 0
Sample Output
Escaped in 11 minute(s).
Trapped!
然后是别的大佬的代码(不知道是哪位大佬的,反正在 http://blog.csdn.net/libin56842/article/details/23702395 能看到)
#include <iostream>  
#include <stdio.h>  
#include <string.h>  
#include <queue>  
#include <algorithm>  
using namespace std;  
  
char map[35][35][35];  
int vis[35][35][35];  
int k,n,m,sx,sy,sz,ex,ey,ez;  
int to[6][3] = {{0,0,1},{0,0,-1},{0,1,0},{0,-1,0},{1,0,0},{-1,0,0}};  
  
struct node  
{  
    int x,y,z,step;  
};  
  
int check(int x,int y,int z)  
{  
    if(x<0 || y<0 || z<0 || x>=k || y>=n || z>=m)  
        return 1;  
    else if(map[x][y][z] == '#')  
        return 1;  
    else if(vis[x][y][z])  
        return 1;  
    return 0;  
}  
  
int bfs()   ///广搜 
{  
    int i;  
    node a,next;   
    queue<node> Q;  ///node 结构体 
    a.x = sx,a.y = sy,a.z = sz;  
    a.step = 0;  
    vis[sx][sy][sz] = 1;  
    Q.push(a);  
    while(!Q.empty())  
    {  
        a = Q.front();  
        Q.pop();  
        if(a.x == ex && a.y == ey && a.z == ez)  
            return a.step;  
        for(i = 0; i<6; i++)  
        {  
            next = a;  
            next.x = a.x+to[i][0];  
            next.y = a.y+to[i][1];  
            next.z = a.z+to[i][2];  
            if(check(next.x,next.y,next.z))  
                continue;  
            vis[next.x][next.y][next.z] = 1;  
            next.step = a.step+1;  
            Q.push(next);  
        }  
    }  
    return 0;  
}  
  
int main()  
{  
    int i,j,r;  
    while(scanf("%d%d%d",&k,&n,&m),n+m+k)  
    {  
        for(i = 0; i<k; i++)  
        {  
            for(j = 0; j<n; j++)  
            {  
                scanf("%s",map[i][j]);  
                for(r = 0; r<m; r++)  
                {  
                    if(map[i][j][r] == 'S')  
                    {  
                        sx = i,sy = j,sz = r;  
                    }  
                    else if(map[i][j][r] == 'E')  
                    {  
                        ex = i,ey = j,ez = r;  
                    }  
                }  
            }  
        }  
        memset(vis,0,sizeof(vis));  
        int ans;  
        ans = bfs();  
        if(ans)  
            printf("Escaped in %d minute(s).\n",ans);  
        else  
            printf("Trapped!\n");  
    }  
  
    return 0;  
}  

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章