Sicily 1209 Sequence Sum Possibi

Constraints

Time Limit: 1 secs, Memory Limit: 32 MB

Description

Most positive integers may be written as a sum of a sequence of at least two consecutive positive integers. For instance,

6 = 1 + 2 + 3
9 = 5 + 4 = 2 + 3 + 4

but 8 cannot be so written.

Write a program which will compute how many different ways an input number may be written as a sum of a sequence of at least two consecutive positive integers.

Input

The first line of input will contain the number of problem instances N on a line by itself, (1<=N<=1000) . This will be followed by N lines, one for each problem instance. Each problem line will have the problem number, a single space and the number to be written as a sequence of consecutive positive integers. The second number will be less than 2^31 (so will fit in a 32-bit integer).

Output

The output for each problem instance will be a single line containing the problem number, a single space and the number of ways the input number can be written as a sequence of consecutive positive integers.

Sample Input

7 
1 6 
2 9 
3 8 
4 1800 
5 987654321 
6 987654323 
7 987654325

Sample Output

1 1 
2 2 
3 0 
4 8 
5 17 
6 1 
7 23

Solution

題目大意是給定n,求n可以由等於多少段連續自然數之和。

數學題,我一開始想的是直接窮舉起點和終點,但是無論怎麼優化都是會超時的

然後就學到枚舉項數,反過來算起點是不是整數來判斷是不是一個合法的解,注意項數的上限。

#include <iostream>

using namespace std;

int main()
{
  int t;

  cin >> t;
  while ( t -- )
  {
    int i, j, t_case, n, count = 0;

    cin >> t_case >> n;
    for ( i = 2; i * i - i < 2 * n; i ++ )//項數枚舉
    {
      if ( (n - i * ( i - 1 ) / 2) % i == 0 ) count ++;
    }
    cout << t_case << ' ' << count << '\n';
  }

  return 0;
}
//兩個限制條件,整除和枚舉的不是起點和終點,而是項數,通過項數反算起點是否爲整數


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章