PAT (Advanced Level) Practise 1021. Deepest Root (25)

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:

Error: 2 components

代碼:

#include <cstdio>
#include <cstring>
#include <vector>
#include <algorithm>
using namespace std;

const int maxn=10010;
vector<int> G[maxn];
int tree[maxn];

int findRoot(int x){
    if(tree[x]==-1) return x;
    else{
        int tmp=findRoot(tree[x]);
        tree[x]=tmp;
        return tmp;
    }
}

int maxh=0;
vector<int> temp,ans;

void dfs(int u,int h,int pre){
    if(h>maxh){
        temp.clear();
        temp.push_back(u);
        maxh=h;
    }
    else if(h==maxh) temp.push_back(u);
    for(int i=0;i<G[u].size();i++){
        if(G[u][i]==pre) continue;
        dfs(G[u][i],h+1,u);
    }
}

int main(){
    int n,a,b;
    scanf("%d",&n);
    for(int i=1;i<=n;i++) tree[i]=-1;
    for(int i=1;i<n;i++){
        scanf("%d%d",&a,&b);
        G[a].push_back(b);
        G[b].push_back(a);
        a=findRoot(a);
        b=findRoot(b);
        if(a!=b) tree[a]=b;
    }
    int block=0;
    for(int i=1;i<=n;i++) if(tree[i]==-1) block++;
    if(block!=1) printf("Error: %d components\n",block);
    else{
        dfs(1,1,-1);
        ans=temp;
        dfs(ans[0],1,-1);
        for(int i=0;i<temp.size();i++) ans.push_back(temp[i]);
        sort(ans.begin(),ans.end());
        printf("%d\n",ans[0]);
        for(int i=1;i<ans.size();i++){
            if(ans[i]!=ans[i-1]) printf("%d\n",ans[i]);
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章