HDU1008Elevator

題目描述:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

思路:

水題一個,nextpost記錄下一個要去的位置,lastpost記錄上一個要去的位置。

  1. nextpost大於lastpost時,相減乘6
  2. nextpost大於lastpost時,相減乘4
  3. 每輸入一個,sum必加5

代碼如下

#include<iostream>
#include<stdio.h>
#include<cstring>
#include<algorithm>
#include<stdlib.h>
#define MAXN 101
using namespace std;
int main()
{
    int N, i, nextpost, lastpost,sum;
    while (cin >> N&& N) {
        lastpost = 0;
        sum = 0;
        for (i = 0; i < N; i++) {
            cin >> nextpost;
            if (nextpost < lastpost)
                sum = sum + (lastpost - nextpost) * 4;
            else {
                sum = sum + (nextpost - lastpost) * 6;
            }
            lastpost = nextpost;
            sum = sum + 5;
        }
        cout << sum << endl;

    }
    return 0;
}
//水題一個
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章