Problem L. Graph Theory Homework

Problem L. Graph Theory Homework

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 2408    Accepted Submission(s): 1054


 

Problem Description

There is a complete graph containing n vertices, the weight of the i-th vertex is wi.
The length of edge between vertex i and j (i≠j) is ⌊|wi−wj|−−−−−−−√⌋.
Calculate the length of the shortest path from 1 to n.

 

 

Input

The first line of the input contains an integer T (1≤T≤10) denoting the number of test cases.
Each test case starts with an integer n (1≤n≤105) denoting the number of vertices in the graph.
The second line contains n integers, the i-th integer denotes wi (1≤wi≤105).

 

 

Output

For each test case, print an integer denoting the length of the shortest path from 1 to n.

 

 

Sample Input


 

1 3 1 3 5

 

 

Sample Output


 

2

代碼:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>

using namespace std;  

const int MAXN = 1e5+10;  
struct Node {
    int value;  
    int dian;
}node[MAXN];

int main(){
    int T;  
    scanf("%d", &T);  
    while(T--){
        int n;  
        scanf("%d", &n);  
        for(int i=1; i<=n; i++){
            scanf("%d", &node[i].value); 
            node[i].dian=i;  
        }
        
        int ans = sqrt(abs(node[1].value - node[n].value));  
        printf("%d\n", ans);  
    }
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章