Tree Recovery

Poj2255:

Tree Recovery

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

Source


//先序遍歷:DBACEGF
//中序遍歷:ABCDEFG
//先序遍歷額第一個字符D即爲根節點;
//中序中D的左邊的均爲左子樹節點,右邊即爲右子樹節點;
//先序中第二個字符B即爲左子樹的根節點;
//中序中以B爲根節點的左子樹節點只有A,右子樹包含C,D;
//以此遞歸建樹,後序輸出當前根節點。

#include <iostream>
#include <cstring>
using namespace std;
void build(int n,char *s1,char *s2)//n表示節點的個數;
{
    if(n<=0) return;
    int p=strchr(s2,s1[0])-s2;//找到根節點在中序遍歷中的位置;
    build(p,s1+1,s2);//遞歸構造左子數;
    build(n-p-1,s1+p+1,s2+p+1);//遞歸構造右子樹;
    cout<<s1[0];//後序輸出根節點;
}
int main()
{
    char s1[100],s2[100];
    while(cin>>s1>>s2)
    {
        int n=strlen(s1);
        build(n,s1,s2);
        cout<<'\n';
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章