113 - Power of Cryptography

Uva

113 - Power of Cryptography


 Power of Cryptography 

Background

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest.

This problem involves the efficient computation of integer roots of numbers.

The Problem

Given an integer tex2html_wrap_inline32 and an integer tex2html_wrap_inline34 you are to write a program that determines tex2html_wrap_inline36 , the positive tex2html_wrap_inline38 root of p. In this problem, given such integers n and pp will always be of the form tex2html_wrap_inline48 for an integer k (this integer is what your program must find).

The Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs tex2html_wrap_inline56 ,tex2html_wrap_inline58 and there exists an integer ktex2html_wrap_inline62 such that tex2html_wrap_inline64 .

The Output

For each integer pair n and p the value tex2html_wrap_inline36 should be printed, i.e., the number k such that tex2html_wrap_inline64 .

Sample Input

2
16
3
27
7
4357186184021382204544

Sample Output

4
3
1234

p不是很大,可以用double(最大1.8*10^308)存儲。

k^n=p,經變換有k=p^(1/n),可用math.h中的pow()函數,或

對兩邊取對數,有n*ln(k)=ln(p)  => ln(k)=ln(p)/n =>k=e^(ln(p)/n),求ln(p),可以math.h中的log()函數

或者複雜一點用 二分+高精度

#include <iostream>
#include <cmath>
using namespace std;

int main()
{
    double n,p;
    while(cin>>n>>p)
        cout<<(int)(pow(p,1.0/n)+0.5)<<endl;//在貌似poj的數據數據較水,注意精度;
    return 0;
}


#include <iostream>
#include <cmath>
using namespace std;
int main(int argc, char **argv)
{
	double n,p;
    while(cin>>n>>p)
        cout<<(int)(exp(log(p)/n)+0.5)<<endl;
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章