Tree Recovery

Poj2255:

Tree Recovery

Description

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly looking binary trees with capital letters in the nodes. 
This is an example of one of her creations: 
                                               D

                                              / \

                                             /   \

                                            B     E

                                           / \     \

                                          /   \     \

                                         A     C     G

                                                    /

                                                   /

                                                  F


To record her trees for future generations, she wrote down two strings for each tree: a preorder traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree). For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG. 
She thought that such a pair of strings would give enough information to reconstruct the tree later (but she never tried it). 

Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed possible, but only because she never had used the same letter twice in the same tree. 
However, doing the reconstruction by hand, soon turned out to be tedious. 
So now she asks you to write a program that does the job for her! 

Input

The input will contain one or more test cases. 
Each test case consists of one line containing two strings preord and inord, representing the preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters. (Thus they are not longer than 26 characters.) 
Input is terminated by end of file. 

Output

For each test case, recover Valentine's binary tree and print one line containing the tree's postorder traversal (left subtree, right subtree, root).

Sample Input

DBACEGF ABCDEFG
BCAD CBAD

Sample Output

ACBFGED
CDAB

Source


//先序遍历:DBACEGF
//中序遍历:ABCDEFG
//先序遍历额第一个字符D即为根节点;
//中序中D的左边的均为左子树节点,右边即为右子树节点;
//先序中第二个字符B即为左子树的根节点;
//中序中以B为根节点的左子树节点只有A,右子树包含C,D;
//以此递归建树,后序输出当前根节点。

#include <iostream>
#include <cstring>
using namespace std;
void build(int n,char *s1,char *s2)//n表示节点的个数;
{
    if(n<=0) return;
    int p=strchr(s2,s1[0])-s2;//找到根节点在中序遍历中的位置;
    build(p,s1+1,s2);//递归构造左子数;
    build(n-p-1,s1+p+1,s2+p+1);//递归构造右子树;
    cout<<s1[0];//后序输出根节点;
}
int main()
{
    char s1[100],s2[100];
    while(cin>>s1>>s2)
    {
        int n=strlen(s1);
        build(n,s1,s2);
        cout<<'\n';
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章