Rails

Poj1363:

Rails

Description

There is a famous railway station in PopPush City. Country there is incredibly hilly. The station was built in last century. Unfortunately, funds were extremely limited that time. It was possible to establish only a surface track. Moreover, it turned out that the station could be only a dead-end one (see picture) and due to lack of available space it could have only one track. 

The local tradition is that every train arriving from the direction A continues in the direction B with coaches reorganized in some way. Assume that the train arriving from the direction A has N <= 1000 coaches numbered in increasing order 1, 2, ..., N. The chief for train reorganizations must know whether it is possible to marshal coaches continuing in the direction B so that their order will be a1, a2, ..., aN. Help him and write a program that decides whether it is possible to get the required order of coaches. You can assume that single coaches can be disconnected from the train before they enter the station and that they can move themselves until they are on the track in the direction B. You can also suppose that at any time there can be located as many coaches as necessary in the station. But once a coach has entered the station it cannot return to the track in the direction A and also once it has left the station in the direction B it cannot return back to the station. 

Input

The input consists of blocks of lines. Each block except the last describes one train and possibly more requirements for its reorganization. In the first line of the block there is the integer N described above. In each of the next lines of the block there is a permutation of 1, 2, ..., N. The last line of the block contains just 0. 

The last block consists of just one line containing 0.

Output

The output contains the lines corresponding to the lines with permutations in the input. A line of the output contains Yes if it is possible to marshal the coaches in the order required on the corresponding line of the input. Otherwise it contains No. In addition, there is one empty line after the lines corresponding to one block of the input. There is no line in the output corresponding to the last ``null'' block of the input.

Sample Input

5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0

Sample Output

Yes
No

Yes

Source


一直沒明白題目的意思...百度了N篇文章,才揭開了我的疑惑。

題目大意:有按1~n標號的火車箱,經過棧處理後,能否與給出的序列相匹配,能就輸出Yes,否則No。

比如說1 2 3 4 5,火車箱進一個立即出一個就能滿足。

在如5 4 3 2 1,火車一下全部進棧,在出棧就能滿足,6 5 4 3 2 1同理;

而 5 4 1 2 3,無論你怎麼安排入棧出棧都無法實現的。

參考劉汝佳白皮書:

#include <iostream>

using namespace std;
const int maxn=1000+10;
int main()
{
    int n;
    while(cin>>n&&n)
    {
        int target[maxn];
        while(cin>>target[1]&&target[1])
        {
            int stack[maxn],top=0;
            int A=1,B=1;
            for(int i=2;i<=n;i++)
                cin>>target[i];
            int ok=1;
            while(B<=n)
            {
                if(A==target[B]){A++;B++;}
                else if(top&&stack[top]==target[B]){top--;B++;}
                else if(A<=n){stack[++top]=A++;}
                else {ok=0;break;}
            }
            if(ok)
                cout<<"Yes\n";
            else
                cout<<"No\n";
        }
        cout<<'\n';
    }
    return 0;
}

#include <iostream>
#include <stack>
using namespace std;
const int maxn=1000+10;
int main()
{
    int n;
    while(cin>>n&&n)
    {
        int target[maxn];
        while(cin>>target[1]&&target[1])
        {
            stack<int>q;
            int A=1,B=1;
            for(int i=2;i<=n;i++)
                cin>>target[i];
            int ok=1;
            while(B<=n)
            {
                if(A==target[B]){A++;B++;}
                else if(!q.empty()&&q.top()==target[B]){q.pop();B++;}
                else if(A<=n){q.push(A++);}
                else {ok=0;break;}
            }
            if(ok)
                cout<<"Yes\n";
            else
                cout<<"No\n";
        }
        cout<<'\n';
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章