POJ 1936 All in All

All in All

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 21411 Accepted: 8511


Description
You have devised a new encryption technique which encodes a message by inserting between its characters randomly generated strings in a clever way. Because of pending patent issues we will not discuss in detail how the strings are generated and inserted into the original message. To validate your method, however, it is necessary to write a program that checks if the message is really encoded in the final string.

Given two strings s and t, you have to decide whether s is a subsequence of t, i.e. if you can remove characters from t such that the concatenation of the remaining characters is s.

Input
The input contains several testcases. Each is specified by two strings s, t of alphanumeric ASCII characters separated by whitespace.The length of s and t will no more than 100000.

Output
For each test case output "Yes", if s is a subsequence of t,otherwise output "No".

Sample Input
sequence subsequence
person compression
VERDI vivaVittorioEmanueleReDiItalia
caseDoesMatter CaseDoesMatter

Sample Output
Yes
No
Yes
No

Source
Ulm Local 2002

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

#define MAXN 100001
char s[MAXN], t[MAXN];
int main(){
	int i, j, k;
	while(scanf("%s %s", s, t) != EOF){
		for (i = j = 0; s[i] && t[j]; i++, j++){
			while(t[j] && s[i] != t[j]) j++;
			if (!t[j]) break;
		}
		if (!s[i]) printf("Yes\n");
		else printf("No\n");
	}
	return 0;
}
/*
貪心地匹配,讓前面的儘量早匹配到,好留給更多的機會給後面
*/


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章