POJ 2635 The Embarrassed Cryptographer

The Embarrassed Cryptographer
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 8984 Accepted: 2316

Description
The young and very promising cryptographer Odd Even has implemented the security module of a large system with thousands of users, which is now in use in his company. The cryptographic keys are created from the product of two primes, and are believed to be secure because there is no known method for factoring such a product effectively.
What Odd Even did not think of, was that both factors in a key should be large, not just their product. It is now possible that some of the users of the system have weak keys. In a desperate attempt not to be fired, Odd Even secretly goes through all the users keys, to check if they are strong enough. He uses his very poweful Atari, and is especially careful when checking his boss' key.

Input
The input consists of no more than 20 test cases. Each test case is a line with the integers 4 <= K <= 10100 and 2 <= L <= 106. K is the key itself, a product of two primes. L is the wanted minimum size of the factors in the key. The input set is terminated by a case where K = 0 and L = 0.

Output
For each number K, if one of its factors are strictly less than the required L, your program should output "BAD p", where p is the smallest factor in K. Otherwise, it should output "GOOD". Cases should be separated by a line-break.

Sample Input
143 10
143 20
667 20
667 30
2573 30
2573 40
0 0

Sample Output
GOOD
BAD 11
GOOD
BAD 23
GOOD
BAD 31

Source
Nordic 2005
#include <stdio.h>
#include <stdlib.h>
#include <string.h>

#define MAXL 110
#define MAXN 1000010

int prime[MAXN], np;
int vis[MAXN];

void calcPrime(){ //被含有其最小質因數的乘積篩掉
	int i, j;
	memset(vis, 1, sizeof(vis));
	np = 0;
	prime[np++] = 2;
	for (i = 3; i < 1000000; i++){
		if (vis[i]) prime[np++] = i;
		for (j = 0; j < np && prime[j] * i <= 1000000; j++){
			vis[prime[j] * i] = 0;
			if (i % prime[j] == 0) break;
		}
	}
}

int main(){
	int i, j, k, p, len;
	int key[MAXL], nk;
	char s[MAXL];
	calcPrime();
	while(scanf("%s %d", s, &p) != EOF && p != 0 && s[0] != '\0'){
		len = strlen(s);
		for (i = len - 1, nk = 0, j = 0, k = 1; i >= 0; i--){
			j = j + k * (s[i] - '0');
			k *= 10;
			if (k == 1000){
				key[nk++] = j;
				j = 0;
				k = 1;
			}
		}
		if (j > 0) key[nk++] = j;
//		for (j = nk - 1; j >= 0; j--) printf("%d ", key[j]);
//		printf("\n");
		for (i = 0; i < np && prime[i] < p; i++){
			k = 0;
			for (j = nk - 1; j >= 0; j--){
				k = k * 1000 +  key[j];
				k = k % prime[i];
			}
//			printf("prime[%d] = %d, k = %d\n", i, prime[i], k);
			if (k == 0) break;
		}
		if (k == 0) printf("BAD %d\n", prime[i]);
		else printf("GOOD\n");
	}
	return 0;
}
/*
高精度模運算,注意累加器k的值不要超過其類型(int)
*/

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章