poj2406PowerString(kmp求循環節)

Power Strings
Time Limit: 3000MS   Memory Limit: 65536K
Total Submissions: 28940   Accepted: 12080

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int MAXN = 1000005;
char pattern[MAXN];
int next[MAXN];

void get_next(){
    next[0]=next[1]=0;
    int m = strlen(pattern);
    for(int i=1; i<m; i++){
        int j = next[i];
        while(j && pattern[i]!=pattern[j]) j = next[j];
        next[i+1] = (pattern[i]==pattern[j]? j+1 : 0);
    }
    int cir = m-next[m];//next[m] 最大爲m-1,故cir最小爲1,最大爲m
    if(m%cir==0) cout<<m/cir<<endl;
    else cout<<1<<endl;
}
int main()
{
    while(scanf("%s",pattern) && pattern[0]!='.'){
        get_next();

    }
    return 0;
}

可打印字符要這樣輸入?

   while(gets(pattern)){
      if(!strcmp(pattern , "."))


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章