hdu1711Number Sequence

Number Sequence

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9148    Accepted Submission(s): 4180


Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
6 -1


#include <iostream>
using namespace std;
const int MAXN = 1000005;
const int MAXM = 10005;
int text[MAXN]; /*文本串*/
int next[MAXM]; /*next數組*/
int pattern[MAXM];/*模式串*/
int m,n,t;

/*O(m)的時間求next數組*/
void get_next(){
    int i=0,j=-1;
    next[i]=j;
    while(i<m){
        if(j==-1 || pattern[i]==pattern[j]){
            i++; j++;
            next[i]=j;
        }else
            j = next[j];
    }
}

/*o(n)的時間進行匹配*/
//void kmp(){
//    int i=0, j=0;
//    while(i<n && j<m){
//        if(j==-1 || text[i]==pattern[j]){
//            i++;
//            j++;
//        }else
//            j=next[j];
//    }
//    if(j>=m) cout<<i-j+1<<endl;
//    else cout<<-1<<endl;
//}


void kmp(){
    int j=0;
    for(int i=0; i<n; i++){
        while(j && text[i]!=pattern[j]) j=next[j];
        if(text[i]==pattern[j]) j++;
        if(j==m) {
            cout<<i-m+2<<endl;
            return;
        }
    }
    cout<<-1<<endl;
}


int main()
{
    cin>>t;
    while(t--){
        cin>>n>>m;
        for(int i=0; i<n; i++) cin>>text[i];
        for(int i=0; i<m; i++) cin>>pattern[i];
        get_next();
        kmp();
    }
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章